[VLAN] load the 8021q module

[Date Prev][Date Next][Thread Prev][Thread Next][Date Index][Thread Index]


Thank you Peter for your writing.  I have another question.  8021q
module does not exist on my Montavista CGE 3.1.  If I want to install
8021q module, can you point me to links to get this module. I have
2.4.20 kernel.


-----Original Message-----
From: vlan-bounces@xxxxxxxxxxxxxxx [mailto:vlan-bounces@xxxxxxxxxxxxxxx]
On Behalf Of Peter Stuge
Sent: Friday, December 23, 2005 11:09 AM
To: vlan@xxxxxxxxxxxxxxx
Subject: Re: [VLAN] load the 8021q module


On Fri, Dec 23, 2005 at 09:54:02AM -0800, Nguyen, HoangX T wrote:
> I have a problem with vlan when I tried to creat a VLAN device on
> my first Ethernet NIC.  I type "vconfig add eth0 5" command, it
> does not create a VLAN device.  Instead of creating a VLAN device,
> the vconfig command returns a message like 
> WARNING: Could not open /proc/net/vlan/config.  Maybe you need to
> load the 8021q module, or maybe you are not using PROCFS??
> ERROR: trying to add VLAN 5 to IF -:eth0:- error: Package not
> installed.
> Questions:
> 1.	How do I load the 8021q module on Montavista CGE 3.1?

I don't know for sure what tools are included in the MontaVista
product, but you could always try the command that is used on less
specialized distributions:

modprobe 8021q

> 2.	What is PROCFS and how do I install PROCFS?

procfs is a virtual filesystem mounted in the /proc directory on
Linux systems. It contains gobs of information published by almost
all parts of the Linux kernel. Some kernel drivers also use procfs
to communicate with userspace in both directions.

> 3.	Where can I get VLAN package and how to install VLAN package?

Footnote on http://www.mvista.com/products/cge/features.html:

"VLAN support requires hardware-specific device driver/ethernet
device support. Contact MontaVista Software for specific
driver/device combinations that have been pre-validated."

So I guess the answer to this is to talk to MontaVista.

> 4.	What do I need to do in order to reproduce the issue above?

Reproduce? Well, you should just have to re-run vconfig. It is
supposed to present the same error message consistently when all it's
prerequisities aren't available.

Resolve? Try the modprobe command as per above, if it completes
without error check that the directory /proc/net/vlan exists and
then re-run vconfig, it should work now.

Hope this helps.

Vlan mailing list

[Index of Archives]     [Netdev]     [Ethernet Bridging]     [Linux Wireless]     [Kernel Newbies]     [Security]     [Linux for Hams]     [Netfilter]     [Bugtraq]     [Yosemite News]     [MIPS Linux]     [ARM Linux]     [Linux RAID]     [Linux Admin]     [Samba]     [Video 4 Linux]

  Powered by Linux