On Tue, Aug 22, 2023 at 02:49:05PM +0200, Mario Marietto wrote: > Hello to everyone. > > I'm trying to use qemu 5.1 with virt-manager and libvirt on my ARM > chromebook (armhf 32 bit cpu) running with Devuan 4 as host o.s. > > By default it uses qemu and its dependencies,version 5.2. I remember that I > can't use qemu 5.2,because it doesn't have any support for KVM as you can > read here : > > > https://lists.gnu.org/archive/html/qemu-devel/2020-09/msg02074.html > > > For this reason,I've compiled qemu 5.1 from source. Below I shown how I > have configured everything such as a little piece of compilation messages : > > > # apt install libgtk-3-dev libpulse-dev libgbm-dev libspice-protocol-dev > libspice-server-dev libusb-1.0-0-dev libepoxy-dev > > > # cp /root/Desktop/qemu-v5.1.0/arm-softmmu/qemu-system-arm /usr/bin > > # CFLAGS=-Wno-error ./configure --target-list=x86_64-softmmu --enable-opengl > --enable-gtk --enable-kvm --enable-guest-agent --enable-spice --audio-drv- > list="oss pa" --enable-libusb > > > A little piece of the log messages that I've got from the compilation of > qemu 5.1 : > > > https://pastebin.ubuntu.com/p/8DYfgPvhXy/ > > > These are the resulting versions of my frankenstein operation : > > > # virsh version > > Compiled against library: libvirt 7.0.0 > Using library: libvirt 7.0.0 > Using API: QEMU 7.0.0 > Running hypervisor: QEMU 5.1.0 > > > At this point I ran virt-manager. It has been able to detect qemu,but I get > the following error : > > > Warning : Failed to set up UEFI. > The Libvirt version does not support UEFI. > Install options are limited. > > (I have also tried upgrading devuan 4 with devuan 5 and I've got the same > error : You most likely need to install qemu-efi-arm package which should provide 32bit arm firmware files. The package name is a bit confusing as it doesn't originate from qemu project, it is from edk2 project. Without this package libvirt most likely doesn't report any efi files and that's what causes the error you are hitting. Pavel > > > root@devuan:/usr/bin# virsh version > > Compiled against library: libvirt 9.0.0 > Using library: libvirt 9.0.0 > Using API: QEMU 9.0.0 > Running hypervisor: QEMU 5.1.0 > > > If I change qemu-system-arm vers. 5.1 with qemu-system-arm 5.2,the error > disappears. So,it seems that libvirt does not accept qemu-system-arm vers. > 5.1 or maybe any version lower than 5.2,I don't know. But as I've said,I > can't use any version of qemu greater or equal to 5.2 on my setup. And I > want to use virt-manager and libvirt because I find these tools very > comfortable instead of using the "raw" qemu parameters. Is there a > workaround ? Maybe I can recompile virt-manager and / or libvirt from the > source code ? but how ? Do you think that it could work if I use something > like this (if it exists and if it can be reached in some way) : > > > Compiled against library: libvirt 5.0.0 > Using library: libvirt 5.0.0 > Using API: QEMU 5.0.0 > Running hypervisor: QEMU 5.1.0 > > > thanks. > > -- > Mario.
Description: PGP signature