On Thu, 2017-08-03 at 14:13 +0100, Radostin Stoyanov wrote: > Split the function mapping_uid_gid in two parts so that the code which > makes both lists `map_uid` and `map_gid` with equal length can be > reused. > --- > src/virtBootstrap/utils.py | 10 ++++++++-- > 1 file changed, 8 insertions(+), 2 deletions(-) > > diff --git a/src/virtBootstrap/utils.py b/src/virtBootstrap/utils.py > index 071bb3e..24209f1 100644 > --- a/src/virtBootstrap/utils.py > +++ b/src/virtBootstrap/utils.py > @@ -530,9 +530,9 @@ def map_id(path, map_uid, map_gid): > os.lchown(file_path, new_uid, new_gid) > > > -def mapping_uid_gid(dest, uid_map, gid_map): > +def balance_uid_gid_maps(uid_map, gid_map): > """ > - Mapping ownership for each uid_map and gid_map. > + Make sure the UID/GID list of mappings have the same lenght. > """ > len_diff = len(uid_map) - len(gid_map) > > @@ -541,5 +541,11 @@ def mapping_uid_gid(dest, uid_map, gid_map): > elif len_diff > 0: > gid_map += [None] * len_diff > > + > +def mapping_uid_gid(dest, uid_map, gid_map): > + """ > + Mapping ownership for each uid_map and gid_map. > + """ > + balance_uid_gid_maps(uid_map, gid_map) > for uid, gid in zip(uid_map, gid_map): > map_id(dest, uid, gid) ACK, but I think I already ACK'ed it -- Cedric _______________________________________________ virt-tools-list mailing list virt-tools-list@xxxxxxxxxx https://www.redhat.com/mailman/listinfo/virt-tools-list