Oops - trivial oversight. Please ignore the v2 patch. Will re-send as v3 after deleting a couple of constants that are no longer used. John On Wed, Nov 15, 2017 at 6:48 PM, <jgroves@xxxxxxxxxx> wrote: > From: John Groves <jgroves@xxxxxxxxxx> > > This patch adds libblkid recognition of Micron mpool formatted devices. > It also adds a very simple crc32c() function, for use by probe_mpool(). > > If there are objections to adding crc32c, I can re-submit without it, or > make it static for probe_mpool(). I would prefer not to go without crc32c > validation, because the only remaining check would be the magic number. > > Review comments and/or questions still welcome. > > Changes since v1: > > * probe_mpool() no longer calls blkid_probe_set_value to set > VALID="yes"|"no". This was debug code that I had failed to excise > previously. > > Thanks, > > John Groves (2): > Add simple crc32c() function > Add support for Micron mpool formatted drives > > include/crc32c.h | 9 +++ > lib/Makemodule.am | 1 + > lib/crc32c.c | 102 +++++++++++++++++++++++++++++++++ > libblkid/src/Makemodule.am | 1 + > libblkid/src/superblocks/mpool.c | 69 ++++++++++++++++++++++ > libblkid/src/superblocks/superblocks.c | 3 +- > libblkid/src/superblocks/superblocks.h | 1 + > 7 files changed, 185 insertions(+), 1 deletion(-) > create mode 100644 include/crc32c.h > create mode 100644 lib/crc32c.c > create mode 100644 libblkid/src/superblocks/mpool.c > > -- > 2.9.3 > -- To unsubscribe from this list: send the line "unsubscribe util-linux" in the body of a message to majordomo@xxxxxxxxxxxxxxx More majordomo info at http://vger.kernel.org/majordomo-info.html