On Fri, Aug 18, 2017 at 08:23:01PM -0400, J William Piggott wrote: > > Signed-off-by: J William Piggott <elseifthen@xxxxxxx> > --- > sys-utils/hwclock.c | 24 +++++++++--------------- > 1 file changed, 9 insertions(+), 15 deletions(-) > > diff --git a/sys-utils/hwclock.c b/sys-utils/hwclock.c > index c398d60..4279931 100644 > --- a/sys-utils/hwclock.c > +++ b/sys-utils/hwclock.c > @@ -601,12 +601,8 @@ display_time(struct timeval hwctime) > * * only on first call after boot > */ > static int > -set_system_clock(const struct hwclock_control *ctl, > - const struct timeval newtime) > +kernel_time_ctl(const struct hwclock_control *ctl, const struct timeval newtime) Hmm... the new name does not make the code more readable for me. We have "HW-clock" (hc) and "system time", would be nice to keep this terminology for functions names too? IMHO set_system_clock() is not so bad :-) (Maybe use system_set_clock() if you want to use "system_" prefix for more functions.) Karel -- Karel Zak <kzak@xxxxxxxxxx> http://karelzak.blogspot.com -- To unsubscribe from this list: send the line "unsubscribe util-linux" in the body of a message to majordomo@xxxxxxxxxxxxxxx More majordomo info at http://vger.kernel.org/majordomo-info.html