[PATCH 00/11] switch to utmpx.h

[Date Prev][Date Next][Thread Prev][Thread Next][Date Index][Thread Index]

 



From: Ruediger Meier <ruediger.meier@xxxxxxxxxxx>

We want to use utmpx instead of utmp becuase it's POSIX.

The first commits of this patch-set are mostly simple cleanup. Then the
final switch to utmpx.h is just renaming work.

Ruediger Meier (11):
  last: include libgen.h for basename(3p)
  login-utils: remove _HAVE_UT_TV fallback
  lslogins: remove useless strlen()
  utmpdump: code formatting for readability
  login-utils: avoid using the defined utmp sizes.
  login: re-add lastlog.h header
  agetty: remove obsolete HAVE_UPDWTMP fallback
  login-utils: switch to utmpx.h
  build-sys: check for POSIX utmpx usage
  travis: let OSX auto-skip utmpx tools
  agetty: re-add utmp.h for Debian GNU/kFreeBSD

 .travis-functions.sh           |  8 -----
 configure.ac                   | 33 +++++++++++------
 include/pathnames.h            |  2 --
 login-utils/last.c             | 81 +++++++++++++++++++++---------------------
 login-utils/login.c            | 52 ++++++++++-----------------
 login-utils/lslogins.c         | 34 ++++++++----------
 login-utils/su-common.c        | 14 ++------
 login-utils/utmpdump.c         | 26 +++++++-------
 term-utils/agetty.c            | 57 +++++++++++------------------
 term-utils/wall.c              |  8 ++---
 term-utils/write.c             | 24 ++++++-------
 tests/expected/paths/built-in  |  1 -
 tests/helpers/test_pathnames.c |  1 -
 13 files changed, 147 insertions(+), 194 deletions(-)

-- 
1.8.5.6

--
To unsubscribe from this list: send the line "unsubscribe util-linux" in
the body of a message to majordomo@xxxxxxxxxxxxxxx
More majordomo info at  http://vger.kernel.org/majordomo-info.html



[Index of Archives]     [Netdev]     [Ethernet Bridging]     [Linux Wireless]     [Kernel Newbies]     [Security]     [Linux for Hams]     [Netfilter]     [Bugtraq]     [Yosemite News]     [MIPS Linux]     [ARM Linux]     [Linux RAID]     [Linux Admin]     [Samba]

  Powered by Linux