[PATCH] namespace.h: Fix typo: s/CLONE_NEWSNS/CLONE_NEWNS/

[Date Prev][Date Next][Thread Prev][Thread Next][Date Index][Thread Index]

 



This typo causes namespace.h to always unconditionally define
CLONE_NEWNS rather than using the system definition.

Bug present since the initial version of unshare in commit
4205f1fda1ac32046125a2e0f3937b666186bfab.

Signed-off-by: Josh Triplett <josh@xxxxxxxxxxxxxxxx>
Signed-off-by: Anton Cherkashyn <mail@xxxxxxxxxx>
---
 include/namespace.h |    2 +-
 1 file changed, 1 insertion(+), 1 deletion(-)

diff --git a/include/namespace.h b/include/namespace.h
index 3a219ce..9d58f13 100644
--- a/include/namespace.h
+++ b/include/namespace.h
@@ -4,7 +4,7 @@
 
 # include <sched.h>
 
-# ifndef CLONE_NEWSNS
+# ifndef CLONE_NEWNS
 #  define CLONE_NEWNS 0x00020000
 # endif
 # ifndef CLONE_NEWUTS
-- 
1.7.10.4

--
To unsubscribe from this list: send the line "unsubscribe util-linux" in
the body of a message to majordomo@xxxxxxxxxxxxxxx
More majordomo info at  http://vger.kernel.org/majordomo-info.html


[Index of Archives]     [Netdev]     [Ethernet Bridging]     [Linux Wireless]     [Kernel Newbies]     [Security]     [Linux for Hams]     [Netfilter]     [Bugtraq]     [Yosemite News]     [MIPS Linux]     [ARM Linux]     [Linux RAID]     [Linux Admin]     [Samba]

  Powered by Linux