Re: [PATCH 2/3] fdisk: api: move disklabel type to cxt

[Date Prev][Date Next][Thread Prev][Thread Next][Date Index][Thread Index]

 



On Wed, Nov 14, 2012 at 12:04:40AM -0800, Davidlohr Bueso wrote:
> -	if (disklabel != DOS_LABEL)
> +	if (cxt->disklabel != DOS_LABEL)

What about to encapsulate it a little? The final goal is to have
libfdisk, so the context members shouldn't not be directly accessible.

   if (fdisk_is_disklabel(cxt, DOS))

something like:

  #define fdisk_is_disklabel(c, x)   fdisk_dev_is_dislabel(c, FDISK_DISKLABEL_ ## x)

to avoid too generic names (e.g. DOS_LABEL), but keep is brief. Note
that we already have a function fdisk_dev_has_label().

    Karel

-- 
 Karel Zak  <kzak@xxxxxxxxxx>
 http://karelzak.blogspot.com
--
To unsubscribe from this list: send the line "unsubscribe util-linux" in
the body of a message to majordomo@xxxxxxxxxxxxxxx
More majordomo info at  http://vger.kernel.org/majordomo-info.html


[Index of Archives]     [Netdev]     [Ethernet Bridging]     [Linux Wireless]     [Kernel Newbies]     [Security]     [Linux for Hams]     [Netfilter]     [Bugtraq]     [Yosemite News]     [MIPS Linux]     [ARM Linux]     [Linux RAID]     [Linux Admin]     [Samba]

  Powered by Linux