On Sat, Nov 19, 2011 at 10:43:35PM +0100, Sami Kerola wrote: > chfn: use libc error printing facilities Please, see how the original code uses "msg" in check_gecos_string(). I think that proper fix is: if (msg) warnx (_("%s: '%c' is not allowed"), msg, c); else warnx (_("'%c' is not allowed"), c); and so on... It also seems that check_gecos_string() in main() should be called with static strings, so you can remove the strcats, the strings (e.g. "full name") should be also translated status = check_gecos_string(_("full name"), optarg); see also ask_info() where are the strings too. It would be better to use the same strings :-) > chfn, chsh, setpwnam: use stdbool.h hmm... what about to use old good 'int'? > chfn, chsh: share require password error print definition The macros are horrible. Please, see is_pam_failure() and loginpam_err() in login.c. I think it would be better to create pamfail.h with inline functions / macros. Note that we cannot share this code with login.c where is also necessary to call syslog() and sleep()). > build-sys: trust autotools setting *_SOURCES definitions This commit subject is odd... do you mean "fix coding style"? :-) Karel -- Karel Zak <kzak@xxxxxxxxxx> http://karelzak.blogspot.com -- To unsubscribe from this list: send the line "unsubscribe util-linux" in the body of a message to majordomo@xxxxxxxxxxxxxxx More majordomo info at http://vger.kernel.org/majordomo-info.html