Re: [PATCH 06/10] gpiolib: refactor gpio-line-names parsing

[Date Prev][Date Next][Thread Prev][Thread Next][Date Index][Thread Index]

 



On 02.06.23 09:49, Marco Felsch wrote:
> Move the gpio-line-names parsing out of of_gpiochip_scan_hogs() since
> this has nothing to do with gpio-hogs. The new function is very similar
> with the kernel function devprop_gpiochip_set_names().
> 
> Signed-off-by: Marco Felsch <m.felsch@xxxxxxxxxxxxxx>

Reviewed-by: Ahmad Fatoum <a.fatoum@xxxxxxxxxxxxxx>

> ---
>  drivers/gpio/gpiolib.c | 104 ++++++++++++++++++++++++++---------------
>  1 file changed, 66 insertions(+), 38 deletions(-)
> 
> diff --git a/drivers/gpio/gpiolib.c b/drivers/gpio/gpiolib.c
> index 166356c85a..127cc60abd 100644
> --- a/drivers/gpio/gpiolib.c
> +++ b/drivers/gpio/gpiolib.c
> @@ -515,48 +515,11 @@ static int of_hog_gpio(struct device_node *np, struct gpio_chip *chip,
>  static int of_gpiochip_scan_hogs(struct gpio_chip *chip)
>  {
>  	struct device_node *np;
> -	int ret, i, count;
> +	int ret, i;
>  
>  	if (!IS_ENABLED(CONFIG_OFDEVICE) || !chip->dev->of_node)
>  		return 0;
>  
> -	count = of_property_count_strings(chip->dev->of_node,
> -					  "gpio-line-names");
> -
> -	if (count > 0) {
> -		const char **names = xzalloc(count * sizeof(char *));
> -
> -		ret = of_property_read_string_array(chip->dev->of_node,
> -						    "gpio-line-names", names,
> -						    count);
> -		if (ret < 0) {
> -			dev_warn(chip->dev, "failed to read GPIO line names\n");
> -			kfree(names);
> -			return ret;
> -		}
> -
> -		/*
> -		 * Since property 'gpio-line-names' cannot contains gaps, we
> -		 * have to be sure we only assign those pins that really exists
> -		 * since chip->ngpio can be less.
> -		 */
> -		if (count > chip->ngpio)
> -			count = chip->ngpio;
> -
> -		for (i = 0; i < count; i++) {
> -			/*
> -			 * Allow overriding "fixed" names provided by the GPIO
> -			 * provider. The "fixed" names are more often than not
> -			 * generic and less informative than the names given in
> -			 * device properties.
> -			 */
> -			if (names[i] && names[i][0])
> -				gpio_desc[chip->base + i].name = names[i];
> -		}
> -
> -		free(names);
> -	}
> -
>  	for_each_available_child_of_node(chip->dev->of_node, np) {
>  		if (!of_property_read_bool(np, "gpio-hog"))
>  			continue;
> @@ -576,6 +539,66 @@ static int of_gpiochip_scan_hogs(struct gpio_chip *chip)
>  	return 0;
>  }
>  
> +/*
> + * of_gpiochip_set_names - Set GPIO line names using OF properties
> + * @chip: GPIO chip whose lines should be named, if possible
> + *
> + * Looks for device property "gpio-line-names" and if it exists assigns
> + * GPIO line names for the chip. The memory allocated for the assigned
> + * names belong to the underlying firmware node and should not be released
> + * by the caller.
> + */
> +static int of_gpiochip_set_names(struct gpio_chip *chip)
> +{
> +	struct device *dev = chip->dev;
> +	struct device_node *np;
> +	const char **names;
> +	int ret, i, count;
> +
> +	np = dev_of_node(dev);
> +	if (!np)
> +		return 0;
> +
> +	count = of_property_count_strings(np, "gpio-line-names");
> +	if (count < 0)
> +		return 0;
> +
> +	names = kcalloc(count, sizeof(*names), GFP_KERNEL);
> +	if (!names)
> +		return -ENOMEM;
> +
> +	ret = of_property_read_string_array(np, "gpio-line-names",
> +					    names, count);
> +	if (ret < 0) {
> +		dev_warn(dev, "failed to read GPIO line names\n");
> +		kfree(names);
> +		return ret;
> +	}
> +
> +	/*
> +	 * Since property 'gpio-line-names' cannot contains gaps, we
> +	 * have to be sure we only assign those pins that really exists
> +	 * since chip->ngpio can be less.
> +	 */
> +	if (count > chip->ngpio)
> +		count = chip->ngpio;
> +
> +	for (i = 0; i < count; i++) {
> +		/*
> +		 * Allow overriding "fixed" names provided by the GPIO
> +		 * provider. The "fixed" names are more often than not
> +		 * generic and less informative than the names given in
> +		 * device properties.
> +		 */
> +		if (names[i] && names[i][0])
> +			gpio_desc[chip->base + i].name = names[i];
> +	}
> +
> +	free(names);
> +
> +	return 0;
> +}
> +
>  #ifdef CONFIG_OFDEVICE
>  static const char *gpio_suffixes[] = {
>  	"gpios",
> @@ -637,6 +660,7 @@ int dev_gpiod_get_index(struct device *dev,
>  
>  int gpiochip_add(struct gpio_chip *chip)
>  {
> +	int ret;
>  	int i;
>  
>  	if (chip->base >= 0) {
> @@ -656,6 +680,10 @@ int gpiochip_add(struct gpio_chip *chip)
>  	for (i = chip->base; i < chip->base + chip->ngpio; i++)
>  		gpio_desc[i].chip = chip;
>  
> +	ret = of_gpiochip_set_names(chip);
> +	if (ret)
> +		return ret;
> +
>  	return of_gpiochip_scan_hogs(chip);
>  }
>  

-- 
Pengutronix e.K.                           |                             |
Steuerwalder Str. 21                       | http://www.pengutronix.de/  |
31137 Hildesheim, Germany                  | Phone: +49-5121-206917-0    |
Amtsgericht Hildesheim, HRA 2686           | Fax:   +49-5121-206917-5555 |





[Index of Archives]     [Linux Embedded]     [Linux USB Devel]     [Linux Audio Users]     [Yosemite News]     [Linux Kernel]     [Linux SCSI]     [XFree86]

  Powered by Linux