With the previous message I misunderstood that the 'configuration mismatch' was caused by any entity forcing the dr_mode to 'host'/'device'. The actual intention however is to tell the user that the selected 'dr_mode' does not match the capabilities provided by the controller or the selected driver parts (USB_DWC2_HOST/USB_DWC2_GADGET). The updated warning message attempts to reflect this more explicitly. Also rename 'device' to 'peripheral' as it is named both in dtb and in macros that way. Signed-off-by: Enrico Jorns <ejo@xxxxxxxxxxxxxx> --- drivers/usb/dwc2/core.c | 4 ++-- 1 file changed, 2 insertions(+), 2 deletions(-) diff --git a/drivers/usb/dwc2/core.c b/drivers/usb/dwc2/core.c index cc5729ed92..6dfe14f174 100644 --- a/drivers/usb/dwc2/core.c +++ b/drivers/usb/dwc2/core.c @@ -672,8 +672,8 @@ int dwc2_get_dr_mode(struct dwc2 *dwc2) if (mode != dwc2->dr_mode) { dwc2_warn(dwc2, - "Configuration mismatch. dr_mode forced to %s\n", - mode == USB_DR_MODE_HOST ? "host" : "device"); + "Selected dr_mode not supported by controller/driver. Enforcing '%s' mode.\n", + mode == USB_DR_MODE_HOST ? "host" : "peripheral"); dwc2->dr_mode = mode; } -- 2.29.2 _______________________________________________ barebox mailing list barebox@xxxxxxxxxxxxxxxxxxx http://lists.infradead.org/mailman/listinfo/barebox