On Thu, May 14, 2020 at 08:21:56PM +0200, Daniel Glöckner wrote: > There is nothing USB-specific in the defined usbgadget.fastboot_* > variables. Rename them to be usable also for the UDP fastboot transport. > > The usbgadget.fastboot_function variable is used to define the files and > devices accessible with the erase and flash commands. Since "function" is > a term from the USB specification and the Fastboot specification uses the > term "partition", we rename that variable to "fastboot.partitions". > > Signed-off-by: Daniel Glöckner <dg@xxxxxxxxx> > --- > Documentation/user/usb.rst | 4 ++-- > commands/usbgadget.c | 2 +- > common/fastboot.c | 15 +++++++++++++-- > common/usbgadget.c | 16 ++-------------- > include/fastboot.h | 3 +++ > 5 files changed, 21 insertions(+), 19 deletions(-) > > diff --git a/Documentation/user/usb.rst b/Documentation/user/usb.rst > device_initcall(fastboot_globalvars_init); > > -BAREBOX_MAGICVAR_NAMED(global_usbgadget_fastboot_max_download_size, > - global.usbgadget.fastboot_max_download_size, > +BAREBOX_MAGICVAR_NAMED(global_fastboot_max_download_size, > + global.fastboot.max_download_size, > "Fastboot maximum download size"); This renames the magicvar description for this variable, but not the variable itself. Sascha -- Pengutronix e.K. | | Steuerwalder Str. 21 | http://www.pengutronix.de/ | 31137 Hildesheim, Germany | Phone: +49-5121-206917-0 | Amtsgericht Hildesheim, HRA 2686 | Fax: +49-5121-206917-5555 | _______________________________________________ barebox mailing list barebox@xxxxxxxxxxxxxxxxxxx http://lists.infradead.org/mailman/listinfo/barebox