Currently, the -A option of mkimage is determined based on $(SRCARCH). I want to rename arch/ppc/ to arch/powerpc/. Support 'powerpc' for the -A option of mkimage beforehand, otherwise the barebox.uimage build would be broken. common/image.c in U-Boot supports both 'powerpc' and 'ppc' for the name of IH_ARCH_PPC. Let's do likewise in barebox. Signed-off-by: Masahiro Yamada <masahiroy@xxxxxxxxxx> --- common/image.c | 1 + 1 file changed, 1 insertion(+) diff --git a/common/image.c b/common/image.c index 39732c57d..8199e2df1 100644 --- a/common/image.c +++ b/common/image.c @@ -47,6 +47,7 @@ static table_entry_t arch_name[] = { { IH_ARCH_MIPS64, "mips64", "MIPS 64 Bit", }, { IH_ARCH_NIOS, "nios", "NIOS", }, { IH_ARCH_NIOS2, "nios2", "NIOS II", }, + { IH_ARCH_PPC, "powerpc", "PowerPC", }, { IH_ARCH_PPC, "ppc", "PowerPC", }, { IH_ARCH_S390, "s390", "IBM S390", }, { IH_ARCH_SH, "sh", "SuperH", }, -- 2.25.1 _______________________________________________ barebox mailing list barebox@xxxxxxxxxxxxxxxxxxx http://lists.infradead.org/mailman/listinfo/barebox