Rename argument of to_pci_dev() to avoid replacing both first and third parameters passed to container_of. All of the current users of the macro invoike it with a varible named "dev", so erroneous replacement doesn't cause any harm, however trying to pass variable with any other name will result in compilation failure. Signed-off-by: Andrey Smirnov <andrew.smirnov@xxxxxxxxx> --- include/linux/pci.h | 2 +- 1 file changed, 1 insertion(+), 1 deletion(-) diff --git a/include/linux/pci.h b/include/linux/pci.h index 478f10207..0022922fc 100644 --- a/include/linux/pci.h +++ b/include/linux/pci.h @@ -113,7 +113,7 @@ struct pci_dev { */ unsigned long base_address[6]; }; -#define to_pci_dev(dev) container_of(dev, struct pci_dev, dev) +#define to_pci_dev(d) container_of(d, struct pci_dev, dev) enum { PCI_BUS_RESOURCE_IO = 0, -- 2.20.1 _______________________________________________ barebox mailing list barebox@xxxxxxxxxxxxxxxxxxx http://lists.infradead.org/mailman/listinfo/barebox