This idiom is repeatead by almost every mci driver, so move it to mci_of_parse() in order to reduce amount of duplicated code. Signed-off-by: Andrey Smirnov <andrew.smirnov@xxxxxxxxx> --- drivers/mci/mci-core.c | 5 +++++ 1 file changed, 5 insertions(+) diff --git a/drivers/mci/mci-core.c b/drivers/mci/mci-core.c index c8d1d5e16..3efd80a8a 100644 --- a/drivers/mci/mci-core.c +++ b/drivers/mci/mci-core.c @@ -1858,6 +1858,7 @@ void mci_of_parse_node(struct mci_host *host, { u32 bus_width; u32 dsr_val; + const char *alias; if (!IS_ENABLED(CONFIG_OFDEVICE)) return; @@ -1865,6 +1866,10 @@ void mci_of_parse_node(struct mci_host *host, if (!host->hw_dev || !np) return; + alias = of_alias_get(np); + if (alias) + host->devname = xstrdup(alias); + /* "bus-width" is translated to MMC_CAP_*_BIT_DATA flags */ if (of_property_read_u32(np, "bus-width", &bus_width) < 0) { /* If bus-width is missing we get the driver's default, which -- 2.19.1 _______________________________________________ barebox mailing list barebox@xxxxxxxxxxxxxxxxxxx http://lists.infradead.org/mailman/listinfo/barebox