Re: [PATCH 1/2] bbu: Look for default handler in barebox_update_handler_exists()

[Date Prev][Date Next][Thread Prev][Thread Next][Date Index][Thread Index]

 



On Thu, Aug 30, 2018 at 10:23:12PM -0700, Andrey Smirnov wrote:
> On Wed, Aug 29, 2018 at 12:58 AM Sascha Hauer <s.hauer@xxxxxxxxxxxxxx> wrote:
> >
> > On Wed, Aug 29, 2018 at 12:21:52AM -0700, Andrey Smirnov wrote:
> > > Convert barebox_update_handler_exists() to treat struct bbu_data with
> > > both "handler_name" and "devicefile" set to NULL as a specifier for
> > > default update handler in order to support such use-case for
> > > "barebox_update" and fix a recent regression.
> > >
> > > This change shouldn't affect another user of
> > > barebox_update_handler_exists(), cb_flash() in
> > > drivers/usb/gadget/f_fastboot.c, since that function explicitly
> > > specifies "devicefile".
> > >
> > > Fixes 0ac96ab6e ("bbu: command: Make sure specified update handler exists")
> > >
> > > Signed-off-by: Andrey Smirnov <andrew.smirnov@xxxxxxxxx>
> > > ---
> > >  common/bbu.c | 2 +-
> > >  1 file changed, 1 insertion(+), 1 deletion(-)
> > >
> > > diff --git a/common/bbu.c b/common/bbu.c
> > > index 3974bf672..ffe5e15a2 100644
> > > --- a/common/bbu.c
> > > +++ b/common/bbu.c
> > > @@ -148,7 +148,7 @@ bool barebox_update_handler_exists(struct bbu_data *data)
> > >       if (handler)
> > >               return true;
> > >
> > > -     if (!data->handler_name)
> > > +     if (!data->handler_name && data->devicefile)
> > >               return false;
> > >
> > >       return bbu_find_handler(data->handler_name) != NULL;
> >
> > This function is confusing. We should split this up into two functions:
> > barebox_update_handler_exists_for_name() and
> > barebox_update_handler_exists_for_devpath() *). Fastboot would only need
> > the latter and the barebox_update command would use both, possibly
> > barking when both a name and a device is given (as otherwise we would
> > have to check for name <-> devpath conflicts)
> >
> 
> What if we just expose already existing bbu_find_handler (potentially
> renaming it to bbu_find_handler_by_name()) and
> bbu_find_handler_by_device() instead and use them as you propose?

That would be fine also.

Sascha


-- 
Pengutronix e.K.                           |                             |
Industrial Linux Solutions                 | http://www.pengutronix.de/  |
Peiner Str. 6-8, 31137 Hildesheim, Germany | Phone: +49-5121-206917-0    |
Amtsgericht Hildesheim, HRA 2686           | Fax:   +49-5121-206917-5555 |

_______________________________________________
barebox mailing list
barebox@xxxxxxxxxxxxxxxxxxx
http://lists.infradead.org/mailman/listinfo/barebox



[Index of Archives]     [Linux Embedded]     [Linux USB Devel]     [Linux Audio Users]     [Yosemite News]     [Linux Kernel]     [Linux SCSI]     [XFree86]

  Powered by Linux