Re: [PATCH v3 24/28] ARM: mmu: Use find_pte() to find PTE in create_vector_table()

[Date Prev][Date Next][Thread Prev][Thread Next][Date Index][Thread Index]

 



On Fri, May 18, 2018 at 1:41 PM, Sam Ravnborg <sam@xxxxxxxxxxxx> wrote:
> Hi Andrey.
>
> On Thu, May 17, 2018 at 01:58:33PM -0700, Andrey Smirnov wrote:
>> There's already a function that implement necessary arithemtic to find
>> offset within page table for a given address, so make use of it
>> instead of re-implementing it again.
>>
>> Signed-off-by: Andrey Smirnov <andrew.smirnov@xxxxxxxxx>
>> ---
>>  arch/arm/cpu/mmu.c | 9 ++++-----
>>  1 file changed, 4 insertions(+), 5 deletions(-)
>>
>> diff --git a/arch/arm/cpu/mmu.c b/arch/arm/cpu/mmu.c
>> index 21394deb1..f9e4d1a50 100644
>> --- a/arch/arm/cpu/mmu.c
>> +++ b/arch/arm/cpu/mmu.c
>> @@ -272,8 +272,7 @@ static void create_vector_table(unsigned long adr)
>>  {
>>       struct resource *vectors_sdram;
>>       void *vectors;
>> -     u32 *exc;
>> -     int idx;
>> +     u32 *pte;
>>
>>       vectors_sdram = request_sdram_region("vector table", adr, PAGE_SIZE);
>>       if (vectors_sdram) {
>> @@ -293,9 +292,9 @@ static void create_vector_table(unsigned long adr)
>>               vectors = xmemalign(PAGE_SIZE, PAGE_SIZE);
>>               pr_debug("Creating vector table, virt = 0x%p, phys = 0x%08lx\n",
>>                        vectors, adr);
>> -             exc = arm_create_pte(adr, pte_flags_uncached);
>> -             idx = (adr & (PGDIR_SIZE - 1)) >> PAGE_SHIFT;
>> -             exc[idx] = (u32)vectors | PTE_TYPE_SMALL | pte_flags_cached;
>> +             arm_create_pte(adr, pte_flags_uncached);
>> +             pte = find_pte(adr);
>> +             *pte = (u32)vectors | PTE_TYPE_SMALL | pte_flags_cached;
>
> This looks more elegant, but the cost here is that
> find_pte() is more expensive than the simple array
> operations done before.
>
> I am not sure if this is needed in followig patches,
> it just looks a bit expensive.
>

The cost of find_pte() is two simple checks and an extra table lookup.
IMHO, seems like a trivial price to pay to avoid code duplication.

Thanks,
Andrey Smirnov

_______________________________________________
barebox mailing list
barebox@xxxxxxxxxxxxxxxxxxx
http://lists.infradead.org/mailman/listinfo/barebox



[Index of Archives]     [Linux Embedded]     [Linux USB Devel]     [Linux Audio Users]     [Yosemite News]     [Linux Kernel]     [Linux SCSI]     [XFree86]

  Powered by Linux