[PATCH] elf.h: Use EI_NIDENT instead of numeric value

[Date Prev][Date Next][Thread Prev][Thread Next][Date Index][Thread Index]

 



This is an adoption of the linux kernel commit

| commit eb6900fbfa43cb50391b80b38608e25280705693
| Author: Cyrill Gorcunov <gorcunov@xxxxxxxxx>
| Date:   Tue Apr 29 01:01:17 2008 -0700
|
|     ELF: Use EI_NIDENT instead of numeric value
|
|     Signed-off-by: Cyrill Gorcunov <gorcunov@xxxxxxxxx>
|     Signed-off-by: Andrew Morton <akpm@xxxxxxxxxxxxxxxxxxxx>
|     Signed-off-by: Linus Torvalds <torvalds@xxxxxxxxxxxxxxxxxxxx>

Signed-off-by: Antony Pavlov <antonynpavlov@xxxxxxxxx>
---
 include/elf.h | 2 +-
 1 file changed, 1 insertion(+), 1 deletion(-)

diff --git a/include/elf.h b/include/elf.h
index a749bec34e..ebcec7db0d 100644
--- a/include/elf.h
+++ b/include/elf.h
@@ -207,7 +207,7 @@ typedef struct elf32_hdr{
 } Elf32_Ehdr;
 
 typedef struct elf64_hdr {
-  unsigned char	e_ident[16];		/* ELF "magic number" */
+  unsigned char	e_ident[EI_NIDENT];	/* ELF "magic number" */
   Elf64_Half e_type;
   Elf64_Half e_machine;
   Elf64_Word e_version;
-- 
2.14.1


_______________________________________________
barebox mailing list
barebox@xxxxxxxxxxxxxxxxxxx
http://lists.infradead.org/mailman/listinfo/barebox



[Index of Archives]     [Linux Embedded]     [Linux USB Devel]     [Linux Audio Users]     [Yosemite News]     [Linux Kernel]     [Linux SCSI]     [XFree86]

  Powered by Linux