On 08/13/13 09:26, Sascha Hauer wrote:
Signed-off-by: Sascha Hauer <s.hauer@xxxxxxxxxxxxxx> --- arch/arm/boards/solidrun-cubox/Makefile | 1 + arch/arm/boards/solidrun-cubox/lowlevel.c | 37 +++++++++++++++++++++++++++++ arch/arm/configs/solidrun_cubox_defconfig | 6 ++++- arch/arm/dts/Makefile | 1 + arch/arm/mach-mvebu/Kconfig | 1 + arch/arm/mach-mvebu/Makefile | 2 +- arch/arm/mach-mvebu/common.c | 4 ++-- arch/arm/mach-mvebu/include/mach/lowlevel.h | 2 +- arch/arm/mach-mvebu/lowlevel.c | 2 +- images/.gitignore | 2 ++ images/Makefile | 4 +++- images/Makefile.mvebu | 26 ++++++++++++++++++++ scripts/Makefile.lib | 3 +++ 13 files changed, 84 insertions(+), 7 deletions(-) create mode 100644 arch/arm/boards/solidrun-cubox/lowlevel.c create mode 100644 images/Makefile.mvebu diff --git a/arch/arm/boards/solidrun-cubox/Makefile b/arch/arm/boards/solidrun-cubox/Makefile index dcfc293..01c7a25 100644 --- a/arch/arm/boards/solidrun-cubox/Makefile +++ b/arch/arm/boards/solidrun-cubox/Makefile @@ -1 +1,2 @@ obj-y += board.o +lwl-y += lowlevel.o diff --git a/arch/arm/boards/solidrun-cubox/lowlevel.c b/arch/arm/boards/solidrun-cubox/lowlevel.c new file mode 100644 index 0000000..fdf5a7e --- /dev/null +++ b/arch/arm/boards/solidrun-cubox/lowlevel.c @@ -0,0 +1,37 @@ +/* + * Copyright (C) 2013 + * Thomas Petazzoni <thomas.petazzoni@xxxxxxxxxxxxxxxxxx> + * Sebastian Hesselbarth <sebastian.hesselbarth@xxxxxxxxx> + * + * This program is free software; you can redistribute it and/or + * modify it under the terms of the GNU General Public License as + * published by the Free Software Foundation; either version 2 of + * the License, or (at your option) any later version. + * + * This program is distributed in the hope that it will be useful, + * but WITHOUT ANY WARRANTY; without even the implied warranty of + * MERCHANTABILITY or FITNESS FOR A PARTICULAR PURPOSE. See the + * GNU General Public License for more details. + * + */ + +#include <common.h> +#include <sizes.h> +#include <asm/barebox-arm.h> +#include <asm/barebox-arm-head.h> +#include <mach/lowlevel.h> + +extern char __dtb_dove_cubox_start[]; + +ENTRY_FUNCTION(start_solidrun_cubox)(void) +{ + uint32_t fdt; + + __barebox_arm_head(); + + arm_cpu_lowlevel_init(); + + fdt = (uint32_t)__dtb_dove_cubox_start - get_runtime_offset(); + + mvebu_barebox_entry(fdt); +}
Sascha, I have tested the series on my CuBox, so you can add my Tested-by. If we find a naming pattern for the entry function above based on the board name, we could also have a macro for it, e.g. rename "start_solidrun_cubox" to "start_dove_cubox". Sebastian _______________________________________________ barebox mailing list barebox@xxxxxxxxxxxxxxxxxxx http://lists.infradead.org/mailman/listinfo/barebox