Re: [PATCH v6 04/18] scsi: Move sd_pr_type to scsi_common

[Date Prev][Date Next][Thread Prev][Thread Next][Date Index][Thread Index]


On 4/7/23 22:05, Mike Christie wrote:
LIO is going to want to do the same block to/from SCSI pr types as sd.c
so this moves the sd_pr_type helper to scsi_common and renames it. The
next patch will then also add a helper to go from the SCSI value to the
block one for use with PERSISTENT_RESERVE_IN commands.

Signed-off-by: Mike Christie <michael.christie@xxxxxxxxxx>
Reviewed-by: Christoph Hellwig <hch@xxxxxx>
Reviewed-by: Chaitanya Kulkarni <kch@xxxxxxxxxx>
  drivers/scsi/scsi_common.c | 22 ++++++++++++++++++++++
  drivers/scsi/sd.c          | 33 ++++++++-------------------------
  include/scsi/scsi_common.h | 12 ++++++++++++
  3 files changed, 42 insertions(+), 25 deletions(-)

Reviewed-by: Hannes Reinecke <hare@xxxxxxx>


Dr. Hannes Reinecke                Kernel Storage Architect
hare@xxxxxxx                              +49 911 74053 688
SUSE Software Solutions GmbH, Maxfeldstr. 5, 90409 Nürnberg
HRB 36809 (AG Nürnberg), Geschäftsführer: Ivo Totev, Andrew
Myers, Andrew McDonald, Martje Boudien Moerman

[Index of Archives]     [Linux SCSI]     [Kernel Newbies]     [Linux SCSI Target Infrastructure]     [Share Photos]     [IDE]     [Security]     [Git]     [Netfilter]     [Bugtraq]     [Yosemite News]     [MIPS Linux]     [ARM Linux]     [Linux Security]     [Linux RAID]     [Linux ATA RAID]     [Linux IIO]     [Device Mapper]

  Powered by Linux