Minor refactoring of core_tmr_abort_task to avoid duplicate code. No functional change here. Signed-off-by: Thinh Nguyen <Thinh.Nguyen@xxxxxxxxxxxx> --- drivers/target/target_core_tmr.c | 6 ++---- 1 file changed, 2 insertions(+), 4 deletions(-) diff --git a/drivers/target/target_core_tmr.c b/drivers/target/target_core_tmr.c index 718d985e4860..3e73f60319d5 100644 --- a/drivers/target/target_core_tmr.c +++ b/drivers/target/target_core_tmr.c @@ -158,15 +158,13 @@ void core_tmr_abort_task( list_del_init(&se_cmd->state_list); target_put_cmd_and_wait(se_cmd); - pr_err("ABORT_TASK: Sending TMR_FUNCTION_COMPLETE for ref_tag: %llu\n", - ref_tag); - tmr->response = TMR_FUNCTION_COMPLETE; atomic_long_inc(&dev->aborts_complete); - return; + goto exit; } spin_unlock_irqrestore(&dev->queues[i].lock, flags); } +exit: printk("ABORT_TASK: Sending TMR_FUNCTION_COMPLETE for ref_tag: %lld\n", tmr->ref_task_tag); tmr->response = TMR_FUNCTION_COMPLETE; -- 2.28.0