Hi all, this series removes the QUEUE_FLAG_SCSI_PASSTHROUGH and thus the last remaining SCSI passthrough concept from the block layer. The changes to support pktcdvd are a bit ugly, but I can't think of anything better (except for removing the driver entirely). If we'd want to support packet writing today it would probably live entirely inside the sr driver. Changes since v2: - s/blk_uniqueue_id/blk_unique_id/g Changes since v1: - use an extra local variable in sd_get_unique_id to make sure we always return the right length - add an enum and a comment to better document ->get_unique_id - spelling fixes Diffstat: block/blk-core.c | 9 -- block/blk-mq-debugfs.c | 1 block/bsg-lib.c | 32 +++---- drivers/block/Kconfig | 2 drivers/block/pktcdvd.c | 7 + drivers/scsi/scsi_bsg.c | 4 drivers/scsi/scsi_error.c | 2 drivers/scsi/scsi_ioctl.c | 4 drivers/scsi/scsi_lib.c | 27 ++++-- drivers/scsi/scsi_scan.c | 1 drivers/scsi/sd.c | 39 +++++++++ drivers/scsi/sg.c | 4 drivers/scsi/sr.c | 2 drivers/scsi/st.c | 2 drivers/target/target_core_pscsi.c | 3 fs/nfsd/Kconfig | 1 fs/nfsd/blocklayout.c | 158 +++++++++---------------------------- fs/nfsd/nfs4layouts.c | 5 - include/linux/blk-mq.h | 5 - include/linux/blkdev.h | 14 ++- include/scsi/scsi_cmnd.h | 3 21 files changed, 148 insertions(+), 177 deletions(-)