Re: [PATCH 11/11] target: move rcu call to the core target code

[Date Prev][Date Next][Thread Prev][Thread Next][Date Index][Thread Index]

 



On 06/21/2017 01:32 PM, Bart Van Assche wrote:
> On Fri, 2017-06-16 at 16:47 -0500, Mike Christie wrote: 
>> +static void target_free_device_call_rcu(struct rcu_head *p)
>> +{
>> +	struct se_device *dev = container_of(p, struct se_device, rcu_head);
>> +
>> +	dev->transport->free_device(dev);
>> +}
> 
> Hello Mike,
> 
> How about calling this function "target_free_device()" and renaming
> "target_free_device()" into "target_destroy_device()"? I think that will make
> the intention of both functions more clear. Otherwise this patch looks fine
> to me.
> 

Oh yeah, nice. Will do.

--
To unsubscribe from this list: send the line "unsubscribe target-devel" in
the body of a message to majordomo@xxxxxxxxxxxxxxx
More majordomo info at  http://vger.kernel.org/majordomo-info.html



[Index of Archives]     [Linux SCSI]     [Kernel Newbies]     [Linux SCSI Target Infrastructure]     [Share Photos]     [IDE]     [Security]     [Git]     [Netfilter]     [Bugtraq]     [Yosemite News]     [MIPS Linux]     [ARM Linux]     [Linux Security]     [Linux RAID]     [Linux ATA RAID]     [Linux IIO]     [Device Mapper]

  Powered by Linux