On Fri, 2017-02-03 at 14:40 -0800, Himanshu Madhani wrote: > + if (fcport->fw_login_state == DSC_LS_PLOGI_COMP) { > + unsigned long t = fcport->plogi_nack_done_jiff + HZ; > + > + if (time_before_eq(jiffies, t)) > + return; > + } The above code occurs two times in this patch. We try to avoid duplicating code in the Linux kernel, especially code that contains hardcoded constants. Have you considered to change the name of plogi_nack_done_jiff into e.g. plogi_done_deadline and to assign jiffies + HZ to that variable instead of jiffies? Bart.-- To unsubscribe from this list: send the line "unsubscribe target-devel" in the body of a message to majordomo@xxxxxxxxxxxxxxx More majordomo info at http://vger.kernel.org/majordomo-info.html