Here is version 2 of the version 2 :) incorporating feedback from Ilias and Nick. Changed in v2: - Change name of SKIPPED bit to UNKNOWN bit - PAD op does not set the bit any more - Change len_op helper functions to take just len_op, not the whole struct - Change version to 2 in missed spots, and use defines - Add 16 unused bytes to cmd_entry.req, in case additional SAM cmd parameters need to be included - Add iov_dif_cnt field to specify buffers used for DIF info in iov[] - Rearrange fields to naturally align cdb_off - Handle if userspace sets UNKNOWN_OP by indicating failure of the cmd - Wrap some overly long UPDATE_HEAD lines Regards -- Andy Andy Grover (2): target: Version 2 of TCMU ABI target: Put TCMU under a new config option Documentation/target/tcmu-design.txt | 43 ++++++++++++++++++++++------------ drivers/target/Kconfig | 5 ++-- drivers/target/Makefile | 2 +- drivers/target/target_core_user.c | 44 +++++++++++++++++++++++++---------- include/uapi/linux/target_core_user.h | 44 +++++++++++++++++++++-------------- 5 files changed, 91 insertions(+), 47 deletions(-) -- 2.1.0 -- To unsubscribe from this list: send the line "unsubscribe target-devel" in the body of a message to majordomo@xxxxxxxxxxxxxxx More majordomo info at http://vger.kernel.org/majordomo-info.html