On Mon, 2015-03-30 at 10:57 +0300, Sagi Grimberg wrote: > On 3/30/2015 6:28 AM, Nicholas A. Bellinger wrote: > > From: Nicholas Bellinger <nab@xxxxxxxxxxxxxxx> > > > > This patch moves the existing target_execute_cmd() check for > > cmd->prot_op into it's own function, so it's easier to add > > future support for WRITE STRIP. > > > > Cc: Martin Petersen <martin.petersen@xxxxxxxxxx> > > Cc: Sagi Grimberg <sagig@xxxxxxxxxxxx> > > Cc: Christoph Hellwig <hch@xxxxxx> > > Signed-off-by: Nicholas Bellinger <nab@xxxxxxxxxxxxxxx> > > --- > > drivers/target/target_core_transport.c | 31 ++++++++++++++++++++++--------- > > 1 file changed, 22 insertions(+), 9 deletions(-) > > > > diff --git a/drivers/target/target_core_transport.c b/drivers/target/target_core_transport.c > > index aef989e..6a24151 100644 > > --- a/drivers/target/target_core_transport.c > > +++ b/drivers/target/target_core_transport.c > > @@ -1738,6 +1738,25 @@ void __target_execute_cmd(struct se_cmd *cmd) > > } > > } > > > > +static int target_check_write_prot(struct se_cmd *cmd) > > This is not really a check routine, it actually does something with > the protection information. Maybe a better name would be > target_write_prot_action() or something in that form. Makes sense. Renamed to target_write_prot_action() -- To unsubscribe from this list: send the line "unsubscribe target-devel" in the body of a message to majordomo@xxxxxxxxxxxxxxx More majordomo info at http://vger.kernel.org/majordomo-info.html