Re: [PATCH 3/3] target/pscsi: Rename sg_num to nr_vecs in pscsi_get_bio()

[Date Prev][Date Next][Thread Prev][Thread Next][Date Index][Thread Index]

 



On Wed, 2013-02-27 at 13:29 +0800, Asias He wrote:
> It is actually a vector not a sg, so nr_vecs is better than sg_num.
> 
> Signed-off-by: Asias He <asias@xxxxxxxxxx>
> ---
>  drivers/target/target_core_pscsi.c | 4 ++--
>  1 file changed, 2 insertions(+), 2 deletions(-)
> 
> diff --git a/drivers/target/target_core_pscsi.c b/drivers/target/target_core_pscsi.c
> index f6921bf..82e78d7 100644
> --- a/drivers/target/target_core_pscsi.c
> +++ b/drivers/target/target_core_pscsi.c
> @@ -840,14 +840,14 @@ static void pscsi_bi_endio(struct bio *bio, int error)
>  	bio_put(bio);
>  }
>  
> -static inline struct bio *pscsi_get_bio(int sg_num)
> +static inline struct bio *pscsi_get_bio(int nr_vecs)
>  {
>  	struct bio *bio;
>  	/*
>  	 * Use bio_malloc() following the comment in for bio -> struct request
>  	 * in block/blk-core.c:blk_make_request()
>  	 */
> -	bio = bio_kmalloc(GFP_KERNEL, sg_num);
> +	bio = bio_kmalloc(GFP_KERNEL, nr_vecs);
>  	if (!bio) {
>  		pr_err("PSCSI: bio_kmalloc() failed\n");
>  		return NULL;

Also applied to for-next.

Thanks Asias!

--nab

--
To unsubscribe from this list: send the line "unsubscribe target-devel" in
the body of a message to majordomo@xxxxxxxxxxxxxxx
More majordomo info at  http://vger.kernel.org/majordomo-info.html


[Index of Archives]     [Linux SCSI]     [Kernel Newbies]     [Linux SCSI Target Infrastructure]     [Share Photos]     [IDE]     [Security]     [Git]     [Netfilter]     [Bugtraq]     [Yosemite News]     [MIPS Linux]     [ARM Linux]     [Linux Security]     [Linux RAID]     [Linux ATA RAID]     [Linux IIO]     [Device Mapper]

  Powered by Linux