On Wed, Dec 04, 2024 at 02:07:19PM +0900, Koichiro Den wrote: > While not harmful, using vq2rxq where it's always sq appears odd. > Replace it with the more appropriate vq2txq for clarity and correctness. > > Fixes: 89f86675cb03 ("virtio_net: xsk: tx: support xmit xsk buffer") > Signed-off-by: Koichiro Den <koichiro.den@xxxxxxxxxxxxx> Acked-by: Michael S. Tsirkin <mst@xxxxxxxxxx> > --- > drivers/net/virtio_net.c | 2 +- > 1 file changed, 1 insertion(+), 1 deletion(-) > > diff --git a/drivers/net/virtio_net.c b/drivers/net/virtio_net.c > index 48ce8b3881b6..1b7a85e75e14 100644 > --- a/drivers/net/virtio_net.c > +++ b/drivers/net/virtio_net.c > @@ -6213,7 +6213,7 @@ static void virtnet_sq_free_unused_buf(struct virtqueue *vq, void *buf) > { > struct virtnet_info *vi = vq->vdev->priv; > struct send_queue *sq; > - int i = vq2rxq(vq); > + int i = vq2txq(vq); > > sq = &vi->sq[i]; > > -- > 2.43.0