10.07.2024 23:09, Markus Elfring wrote:
Add a check to ensure 'sb_getblk' did not return NULL before copying data.
Wording suggestion:
that a sb_getblk() call
How do you think about to use a summary phrase like
“Prevent null pointer dereference in bfs_move_block()”?
Ok, I'll change it in the next version:
bfs: prevent null pointer dereference in bfs_move_block()
Add a check to ensure that a sb_getblk() call did not return NULL before
copying data.
…
+++ b/fs/bfs/file.c
@@ -35,16 +35,22 @@ static int bfs_move_block(unsigned long from, unsigned long to,
struct super_block *sb)
{
struct buffer_head *bh, *new;
+ int err;
Can a statement (like the following) become more appropriate for such
a function implementation?
int ret = 0;
Yes, thank you.
Regards,
Markus
--
Regards,
Vasiliy Kovalev