Re: [PATCH v2] fs/proc/proc_sysctl.c: always initialize i_uid/i_gid

[Date Prev][Date Next][Thread Prev][Thread Next][Date Index][Thread Index]

 



On Fri, Mar 22, 2024 at 08:51:11PM +0100, Thomas Weißschuh wrote:
> Commit e79c6a4fc923 ("net: make net namespace sysctls belong to container's owner")
> added default values for i_uid/i_gid.
> These however are only used when ctl_table_root->set_ownership is not
> implemented.
> But the callbacks themselves could fail to compute i_uid/i_gid and they
> all need to have the same fallback logic for this case.
All this text is related to commit e79c6a4fc923; which is not the one at
fault. I think mentioning e79c6a4fc923 here is incorrect. Please mention
5ec27ec735ba0 ("fs/proc/proc_sysctl.c: fix the default values of
i_uid/i_gid on /proc/sys inodes") and how it missed adjusting
net_ctl_set_ownership when it was committed.

> 
> This is unnecessary code duplication and prone to errors.
> For example net_ctl_set_ownership() missed the fallback.
This paragraph can be dropped

> 
> Instead always initialize i_uid/i_gid inside the sysfs core so
> set_ownership() can safely skip setting them.
> 
> Fixes: e79c6a4fc923 ("net: make net namespace sysctls belong to container's owner")
Why did you leave this? Do you disagree with my comment in
https://lore.kernel.org/all/20240319130716.vne4nhb3mbwtabfb@xxxxxxxxxxxxxxxxxx/?

> Cc: stable@xxxxxxxxxxxxxxx
> Signed-off-by: Thomas Weißschuh <linux@xxxxxxxxxxxxxx>
> ---
> Changes in v2:
> - Move the fallback logic to the sysctl core
> - Link to v1: https://lore.kernel.org/r/20240315-sysctl-net-ownership-v1-1-2b465555a292@xxxxxxxxxxxxxx
> ---
>  fs/proc/proc_sysctl.c | 6 ++----
>  1 file changed, 2 insertions(+), 4 deletions(-)
> 
> diff --git a/fs/proc/proc_sysctl.c b/fs/proc/proc_sysctl.c
> index 37cde0efee57..9e34ab9c21e4 100644
> --- a/fs/proc/proc_sysctl.c
> +++ b/fs/proc/proc_sysctl.c
> @@ -479,12 +479,10 @@ static struct inode *proc_sys_make_inode(struct super_block *sb,
>  			make_empty_dir_inode(inode);
>  	}
>  
> +	inode->i_uid = GLOBAL_ROOT_UID;
> +	inode->i_gid = GLOBAL_ROOT_GID;
>  	if (root->set_ownership)
>  		root->set_ownership(head, table, &inode->i_uid, &inode->i_gid);
> -	else {
> -		inode->i_uid = GLOBAL_ROOT_UID;
> -		inode->i_gid = GLOBAL_ROOT_GID;
> -	}
>  
>  	return inode;
>  }
> 
> ---
> base-commit: ff9c18e435b042596c9d48badac7488e3fa76a55
Now that v6.9-rc1 is out, I would rebase your next version there.


The change looks good, but the commit message still needs work.
-- 

Joel Granados

Attachment: signature.asc
Description: PGP signature


[Index of Archives]     [Linux Kernel]     [Kernel Development Newbies]     [Linux USB Devel]     [Video for Linux]     [Linux Audio Users]     [Yosemite Hiking]     [Linux Kernel]     [Linux SCSI]

  Powered by Linux