On Thu, Apr 30, 2020 at 9:52 AM Andy Lutomirski <luto@xxxxxxxxxx> wrote: > > If I'm going to copy from memory that might be bad but is at least a > valid pointer, I want a function to do this. If I'm going to copy > from memory that might be entirely bogus, that's a different > operation. In other words, if I'm writing e.g. filesystem that is > touching get_user_pages()'d persistent memory, I don't want to panic > if the memory fails, but I do want at least a very loud warning if I > follow a wild pointer. > > So I think that probe_kernel_copy() is not a valid replacement for > memcpy_mcsafe(). Fair enough. That said, the part I do like about probe_kernel_read/write() is that it does indicate which part we think is possibly the one that needs more care. Sure, it _might_ be both sides, but honestly, that's likely the much less common case. Kind of like "copy_{to,from}_user()" vs "copy_in_user()". Yes, the "copy_in_user()" case exists, but it's the odd and unusual case. Looking at the existing cases of "memcpy_mcsafe()", they do seem to generally have a very clearly defined direction, not "both sides can break". I also find myself suspecting that one case people _do_ want to possibly do is to copy from nvdimm memory into user space. So then that needs yet another function. And we have that copy_to_user_mcsafe() for that, and used in the disgustingly named "copyout_mcsafe()". Ugly incomprehensible BSD'ism. But oddly we don't have the "from_user" case. So this thing seems messy, the naming is odd and inconsistent, and I'd really like the whole "access with exception handling" to have some clear rules and clear names. The whole "there are fifty different special cases" really drives me wild. It's why I think the hardware was so broken. And now the special "writes can fault" rule still confuses me. _copy_to_iter_mcsafe() was mentioned, which makes me think that it's literally about that "copy from nvram to user space" issue. But that can't just trap on the destination, that fundamentally needs special user space accesses anyway. Even on x86 you have the whole STAC/CLAC issue, on other architectures the stores may not be normal stores at all. So a "copy_safe()" model doesn't actually work for that at all. So I'm a bit (maybe a _lot_) confused about what the semantics should actually be. And I want the naming to reflect whatever those semantics are. And I don't think "copy_safe()" reflects any semantics at all. Linus