3.16.78-rc1 review patch. If anyone has any objections, please let me know. ------------------ From: Qu Wenruo <wqu@xxxxxxxx> commit 793ff2c88c6397b3531c08cc4f920619b56a9def upstream. Cleanup the following things: 1) open coded SZ_16M round up 2) use min() to replace open-coded size comparison 3) code style Signed-off-by: Qu Wenruo <wqu@xxxxxxxx> Reviewed-by: Nikolay Borisov <nborisov@xxxxxxxx> Reviewed-by: Gu Jinxiang <gujx@xxxxxxxxxxxxxx> [ reformat comment ] Signed-off-by: David Sterba <dsterba@xxxxxxxx> [bwh: Backported to 3.16 as dependency of commit baf92114c7 "btrfs: alloc_chunk: fix more DUP stripe size handling": - Add #include <linux/sizes.h> for definition of SZ_16M] Signed-off-by: Ben Hutchings <ben@xxxxxxxxxxxxxxx> Cc: Hans van Kranenburg <Hans.van.Kranenburg@xxxxxxxxxx> --- --- a/fs/btrfs/volumes.c +++ b/fs/btrfs/volumes.c @@ -27,6 +27,7 @@ #include <linux/kthread.h> #include <linux/raid/pq.h> #include <linux/semaphore.h> +#include <linux/sizes.h> #include <asm/div64.h> #include "ctree.h" #include "extent_map.h" @@ -4273,18 +4274,17 @@ static int __btrfs_alloc_chunk(struct bt * and compare that answer with the max chunk size */ if (stripe_size * data_stripes > max_chunk_size) { - u64 mask = (1ULL << 24) - 1; - stripe_size = div_u64(max_chunk_size, data_stripes); /* bump the answer up to a 16MB boundary */ - stripe_size = (stripe_size + mask) & ~mask; + stripe_size = round_up(stripe_size, SZ_16M); - /* but don't go higher than the limits we found - * while searching for free extents + /* + * But don't go higher than the limits we found while searching + * for free extents */ - if (stripe_size > devices_info[ndevs-1].max_avail) - stripe_size = devices_info[ndevs-1].max_avail; + stripe_size = min(devices_info[ndevs - 1].max_avail, + stripe_size); } /* align to BTRFS_STRIPE_LEN */