On Fri, Jul 12, 2019 at 10:58:03AM +0530, Viresh Kumar wrote: > From: Suzuki K Poulose <suzuki.poulose@xxxxxxx> > > commit fce6361fe9b0caeba0c05b7d72ceda406f8780df upstream. > > This patch moves cpu_die_early to smp.c, where it fits better. > No functional changes, except for adding the necessary checks > for CONFIG_HOTPLUG_CPU. > > Cc: Mark Rutland <mark.rutland@xxxxxxx> > Acked-by: Will Deacon <will.deacon@xxxxxxx> > Signed-off-by: Suzuki K Poulose <suzuki.poulose@xxxxxxx> > Signed-off-by: Catalin Marinas <catalin.marinas@xxxxxxx> > [ Viresh: Resolved rebase conflict ] > Signed-off-by: Viresh Kumar <viresh.kumar@xxxxxxxxxx> > +void cpu_die_early(void) > + asm( > + "1: wfe\n" > + " wfi\n" > + " b 1b"); > +} Rather than open-coding this loop differently from upstream and the v4.9.y backport, please backport commit: c4bc34d20273db69 ("arm64: Add a helper for parking CPUs in a loop") ... as a prerequisite of this patch. Otherwise, this looks fine to me. Thanks, Mark.