On 04/24, Christian Brauner wrote: >On Wed, Apr 24, 2019 at 08:52:38PM +0800, Zhenliang Wei wrote: >> >> Acked-by: Christian Brauner <christian@xxxxxxxxxx> > >I think we're supposed to use more Reviewed-bys so feel free (or Andrew) to change this to: > >Reviewed-by: Christian Brauner <christian@xxxxxxxxxx> Ok, I will change this in patch v5. >> --- a/kernel/signal.c >> +++ b/kernel/signal.c >> @@ -2441,6 +2441,8 @@ bool get_signal(struct ksignal *ksig) >> if (signal_group_exit(signal)) { >> ksig->info.si_signo = signr = SIGKILL; >> sigdelset(¤t->pending.signal, SIGKILL); >> + trace_signal_deliver(SIGKILL, SEND_SIG_NOINFO, >> + &sighand->action[signr - 1]); > >Hm, sorry for being the really nitpicky person here. Just for the sake of consistency how about we do either: > >+ trace_signal_deliver(SIGKILL, SEND_SIG_NOINFO, >+ &sighand->action[SIGKILL - 1]); > >or > >+ trace_signal_deliver(signr, SEND_SIG_NOINFO, >+ &sighand->action[signr - 1]); > >I'm not going to argue about this though. Can just also leave it as is. Thank you for your comments and learn from rigorous people! I will take: + trace_signal_deliver(SIGKILL, SEND_SIG_NOINFO, + &sighand->action[SIGKILL - 1]); Any other suggestions about the patch? Wei