On Fri, Sep 22, 2017 at 06:15:45PM -0400, Steven Rostedt wrote: > From: "Steven Rostedt (VMware)" <rostedt@xxxxxxxxxxx> > > The functionality between kernel_text_address() and _kernel_text_address() > is the same except that _kernel_text_address() does a little more (that > function needs a rename, but that can be done another time). Instead of > having duplicate code in both, simply have _kernel_text_address() calls > kernel_text_address() instead. > > This is marked for stable because there's an RCU bug that can happen if > one of these functions gets called while RCU is not watching. That fix > depends on this fix to keep from having to write the fix twice. > > Cc: Paul E. McKenney <paulmck@xxxxxxxxxxxxxxxxxx> > Cc: stable@xxxxxxxxxxxxxxx > Fixes: 0be964be0 ("module: Sanitize RCU usage and locking") > Signed-off-by: Steven Rostedt (VMware) <rostedt@xxxxxxxxxxx> Not my area, but straightforward transformation and nice reduction in code size. Acked-by: Paul E. McKenney <paulmck@xxxxxxxxxxxxxxxxxx> > --- > kernel/extable.c | 10 +--------- > 1 file changed, 1 insertion(+), 9 deletions(-) > > diff --git a/kernel/extable.c b/kernel/extable.c > index 38c2412401a1..a7024a494faf 100644 > --- a/kernel/extable.c > +++ b/kernel/extable.c > @@ -102,15 +102,7 @@ int core_kernel_data(unsigned long addr) > > int __kernel_text_address(unsigned long addr) > { > - if (core_kernel_text(addr)) > - return 1; > - if (is_module_text_address(addr)) > - return 1; > - if (is_ftrace_trampoline(addr)) > - return 1; > - if (is_kprobe_optinsn_slot(addr) || is_kprobe_insn_slot(addr)) > - return 1; > - if (is_bpf_text_address(addr)) > + if (kernel_text_address(addr)) > return 1; > /* > * There might be init symbols in saved stacktraces. > -- > 2.13.2 > >