> + if (err) { > + if (flags & ADDPART_FLAG_WHOLEDISK) > + goto out_remove_file; > + goto out_del; > + } I'd rather have that if around the actual device_remove_file at the label, and jump to out_remove_file unconditionally. Otherwise this looks fine to me. -- To unsubscribe from this list: send the line "unsubscribe stable" in the body of a message to majordomo@xxxxxxxxxxxxxxx More majordomo info at http://vger.kernel.org/majordomo-info.html