On Mon, Nov 23, 2015 at 03:35:16PM +0100, Peter Zijlstra wrote: > On Mon, Nov 23, 2015 at 03:19:19PM +0100, Frederic Weisbecker wrote: > > On Thu, Nov 19, 2015 at 09:28:28PM +0100, Peter Zijlstra wrote: > > > On Thu, Nov 19, 2015 at 04:47:33PM +0100, Frederic Weisbecker wrote: > > > > +++ b/include/linux/vtime.h > > > > @@ -17,9 +17,20 @@ static inline bool vtime_accounting_cpu_enabled(void) { return true; } > > > > #endif /* CONFIG_VIRT_CPU_ACCOUNTING_NATIVE */ > > > > > > > > #ifdef CONFIG_VIRT_CPU_ACCOUNTING_GEN > > > > +/* > > > > + * Checks if vtime is enabled on some CPU. Cputime readers want to be careful > > > > + * in that case and compute the tickless cputime. > > > > + * For now vtime state is tied to context tracking. We might want to decouple > > > > + * those later if necessary. > > > > + */ > > > > +static inline bool vtime_accounting_enabled(void) > > > > +{ > > > > + return context_tracking_is_enabled(); > > > > +} > > > > > > Should this not also include a definition of this function for > > > CONFIG_VIRT_CPU_ACCOUNTING_NATIVE and CONFIG_VIRT_CPU_ACCOUNTING ? > > > > I could but I haven't found any user of it yet for others than > > CONFIG_VIRT_CPU_ACCOUNTING_GEN. The NATIVE version, when enabled, runs on > > all CPUs anyway. > > Aah, I see, task_gtime() etc.. have a different definition for !GEN. > tricky. Right, this whole CONFIG_VIRT_CPU_ACCOUNTING stuff is a bit messy. I tried to consolidate as much code I could between NATIVE and GEN but the result is hard to parse. I'll see if I can clean a few things up there. To begin with, VIRT_CPU_ACCOUNTING is a horrible misnomer, as vtime. VIRT suggests we are dealing with virtualization while it's absolutely not the case. Perhaps something like BOUNDARY_CPU_ACCOUNTING would parse better. Or TICKLESS_CPU_ACCOUNTING. -- To unsubscribe from this list: send the line "unsubscribe stable" in the body of a message to majordomo@xxxxxxxxxxxxxxx More majordomo info at http://vger.kernel.org/majordomo-info.html