Re: [PATCH] sata_highbank: Rename proc_name to the module name

[Date Prev][Date Next][Thread Prev][Thread Next][Date Index][Thread Index]

 



On 04/30/2013 06:57 PM, Robert Richter wrote:
From: Robert Richter<robert.richter@xxxxxxxxxxx>

mkinitrd looks at /sys/class/scsi_host/host$hostnum/proc_name to find
the module name of a disk driver. Current name is "highbank-ahci" but
the module is "sata_highbank". Rename it to match the module name.

Cc: Rob Herring<rob.herring@xxxxxxxxxxx>
Cc: Alexander Graf<agraf@xxxxxxx>
Cc:<stable@xxxxxxxxxxxxxxx>  v3.7..
Signed-off-by: Robert Richter<robert.richter@xxxxxxxxxxx>

Acked-by: Alexander Graf <agraf@xxxxxxx>


Alex

---
  drivers/ata/sata_highbank.c | 2 +-
  1 file changed, 1 insertion(+), 1 deletion(-)

diff --git a/drivers/ata/sata_highbank.c b/drivers/ata/sata_highbank.c
index 5dba77c..b1a664a 100644
--- a/drivers/ata/sata_highbank.c
+++ b/drivers/ata/sata_highbank.c
@@ -251,7 +251,7 @@ static const struct ata_port_info ahci_highbank_port_info = {
  };

  static struct scsi_host_template ahci_highbank_platform_sht = {
-	AHCI_SHT("highbank-ahci"),
+	AHCI_SHT("sata_highbank"),
  };

  static const struct of_device_id ahci_of_match[] = {

--
To unsubscribe from this list: send the line "unsubscribe stable" in
the body of a message to majordomo@xxxxxxxxxxxxxxx
More majordomo info at  http://vger.kernel.org/majordomo-info.html




[Index of Archives]     [Linux Kernel]     [Kernel Development Newbies]     [Linux USB Devel]     [Video for Linux]     [Linux Audio Users]     [Yosemite Hiking]     [Linux Kernel]     [Linux SCSI]