Patch "random: fix typo in add_timer_randomness()" has been added to the 4.19-stable tree

[Date Prev][Date Next][Thread Prev][Thread Next][Date Index][Thread Index]

 



This is a note to let you know that I've just added the patch titled

    random: fix typo in add_timer_randomness()

to the 4.19-stable tree which can be found at:
    http://www.kernel.org/git/?p=linux/kernel/git/stable/stable-queue.git;a=summary

The filename of the patch is:
     random-fix-typo-in-add_timer_randomness.patch
and it can be found in the queue-4.19 subdirectory.

If you, or anyone else, feels it should not be added to the stable tree,
please let <stable@xxxxxxxxxxxxxxx> know about it.


>From foo@baz Fri Jun 17 08:58:56 AM CEST 2022
From: Yangtao Li <tiny.windzz@xxxxxxxxx>
Date: Tue, 7 Jan 2020 16:55:34 -0500
Subject: random: fix typo in add_timer_randomness()

From: Yangtao Li <tiny.windzz@xxxxxxxxx>

commit 727d499a6f4f29b6abdb635032f5e53e5905aedb upstream.

s/entimate/estimate

Signed-off-by: Yangtao Li <tiny.windzz@xxxxxxxxx>
Link: https://lore.kernel.org/r/20190607182517.28266-4-tiny.windzz@xxxxxxxxx
Signed-off-by: Theodore Ts'o <tytso@xxxxxxx>
Signed-off-by: Jason A. Donenfeld <Jason@xxxxxxxxx>
Signed-off-by: Greg Kroah-Hartman <gregkh@xxxxxxxxxxxxxxxxxxx>
---
 drivers/char/random.c |    2 +-
 1 file changed, 1 insertion(+), 1 deletion(-)

--- a/drivers/char/random.c
+++ b/drivers/char/random.c
@@ -1214,7 +1214,7 @@ static void add_timer_randomness(struct
 	/*
 	 * delta is now minimum absolute delta.
 	 * Round down by 1 bit on general principles,
-	 * and limit entropy entimate to 12 bits.
+	 * and limit entropy estimate to 12 bits.
 	 */
 	credit_entropy_bits(r, min_t(int, fls(delta>>1), 11));
 }


Patches currently in stable-queue which might be from tiny.windzz@xxxxxxxxx are

queue-4.19/random-fix-typo-in-add_timer_randomness.patch
queue-4.19/random-add-and-use-pr_fmt.patch
queue-4.19/random-convert-to-entropy_bits-for-better-code-readability.patch
queue-4.19/random-remove-unnecessary-unlikely.patch
queue-4.19/random-remove-some-dead-code-of-poolinfo.patch



[Date Prev][Date Next][Thread Prev][Thread Next][Date Index][Thread Index]
[Index of Archives]     [Linux USB Devel]     [Linux Audio Users]     [Yosemite News]     [Linux Kernel]     [Linux SCSI]

  Powered by Linux