Patch "mfd: lpc_sch: Rename GPIOBASE to prevent build error" has been added to the 5.10-stable tree

[Date Prev][Date Next][Thread Prev][Thread Next][Date Index][Thread Index]

 



This is a note to let you know that I've just added the patch titled

    mfd: lpc_sch: Rename GPIOBASE to prevent build error

to the 5.10-stable tree which can be found at:
    http://www.kernel.org/git/?p=linux/kernel/git/stable/stable-queue.git;a=summary

The filename of the patch is:
     mfd-lpc_sch-rename-gpiobase-to-prevent-build-error.patch
and it can be found in the queue-5.10 subdirectory.

If you, or anyone else, feels it should not be added to the stable tree,
please let <stable@xxxxxxxxxxxxxxx> know about it.



commit 84c84b8493c064cb7f6bc3a9c2d6d134f8e1745b
Author: Randy Dunlap <rdunlap@xxxxxxxxxxxxx>
Date:   Mon Sep 6 17:19:49 2021 -0700

    mfd: lpc_sch: Rename GPIOBASE to prevent build error
    
    [ Upstream commit cdff1eda69326fb46de10c5454212b3efcf4bb41 ]
    
    One MIPS platform (mach-rc32434) defines GPIOBASE. This macro
    conflicts with one of the same name in lpc_sch.c. Rename the latter one
    to prevent the build error.
    
    ../drivers/mfd/lpc_sch.c:25: error: "GPIOBASE" redefined [-Werror]
       25 | #define GPIOBASE        0x44
    ../arch/mips/include/asm/mach-rc32434/rb.h:32: note: this is the location of the previous definition
       32 | #define GPIOBASE        0x050000
    
    Cc: Denis Turischev <denis@xxxxxxxxxxxxxx>
    Fixes: e82c60ae7d3a ("mfd: Introduce lpc_sch for Intel SCH LPC bridge")
    Signed-off-by: Randy Dunlap <rdunlap@xxxxxxxxxxxxx>
    Signed-off-by: Lee Jones <lee.jones@xxxxxxxxxx>
    Signed-off-by: Sasha Levin <sashal@xxxxxxxxxx>

diff --git a/drivers/mfd/lpc_sch.c b/drivers/mfd/lpc_sch.c
index 428a526cbe86..9ab9adce06fd 100644
--- a/drivers/mfd/lpc_sch.c
+++ b/drivers/mfd/lpc_sch.c
@@ -22,7 +22,7 @@
 #define SMBASE		0x40
 #define SMBUS_IO_SIZE	64
 
-#define GPIOBASE	0x44
+#define GPIO_BASE	0x44
 #define GPIO_IO_SIZE	64
 #define GPIO_IO_SIZE_CENTERTON	128
 
@@ -145,7 +145,7 @@ static int lpc_sch_probe(struct pci_dev *dev, const struct pci_device_id *id)
 	if (ret == 0)
 		cells++;
 
-	ret = lpc_sch_populate_cell(dev, GPIOBASE, "sch_gpio",
+	ret = lpc_sch_populate_cell(dev, GPIO_BASE, "sch_gpio",
 				    info->io_size_gpio,
 				    id->device, &lpc_sch_cells[cells]);
 	if (ret < 0)



[Date Prev][Date Next][Thread Prev][Thread Next][Date Index][Thread Index]
[Index of Archives]     [Linux USB Devel]     [Linux Audio Users]     [Yosemite News]     [Linux Kernel]     [Linux SCSI]

  Powered by Linux