Re: Vdagent not working on a Debian guest

[Date Prev][Date Next][Thread Prev][Thread Next][Date Index][Thread Index]


Something by chance?

El mar, 25 oct 2022 a las 18:16, Carlos González (<piteccelaya@xxxxxxxxx>) escribió:
Already did; it did work, thanks (and yes, it's always Virtual-1 for some reason).
I couldn't understand it very well from the bug report, why isn't it automatically working on some DEs/WMs?

Now, could we focus on the nasty bug with file transferring? As already mentioned, the -f and -o options are serving of absolutely nothing...


El lun, 24 oct 2022 a las 9:16, Uri Lublin (<uril@xxxxxxxxxx>) escribió:
On Thu, Oct 20, 2022 at 11:52 PM Carlos González <piteccelaya@xxxxxxxxx> wrote:
So I did more tests.

First, AntiX Linux by default doesn't use "desktop environments" but "window managers", being the default IceWM. Also, it doesn't use SystemD at all; SysV instead. Regarding Xorg or Wayland, it's Xorg.

> I did some tests and with both Windows and Linux it appears that the
> agent is needed.

Well, of course it's needed! That's per basic instructions...

Since there's no SystemD here, neither journalctl command. So tried running both spice-vdagentd and spice-vdagent with debugging:
sudo /usr/sbin/spice-vdagentd -x -d -d
spice-vdagent -f /path/to/folder -x -d -d

When resizing the remote-viewer window, no logs whatsoever, and of course neither resolution update. Also, using the -f option served of nothing; exact same error mentioned before...
Neither anything at all related in /var/log/Xorg.0.log
*Only* clipboard sharing seems to work

Try the workaround mentioned on the bug, run on the guest (after resizing remote-viewer's window):
    xrandr | grep Virtual                  # look for the connected one
    xrandr --output Virtual-0 --auto # may be Virtual-1 instead of Virtual-0


By chance, do you think you could give the live ISO a try? It's a live system, and the "Base" version is a CD size, not even a DVD...

Thanks again for your attention.

El mié, 19 oct 2022 a las 15:00, Uri Lublin (<uril@xxxxxxxxxx>) escribió:

On Tue, Oct 18, 2022 at 8:40 PM Frediano Ziglio <freddy77@xxxxxxxxx> wrote:
Il giorno mar 18 ott 2022 alle ore 01:04 Carlos González
<piteccelaya@xxxxxxxxx> ha scritto:
> Were you able to find something by chance? Thanks.

Hi Carlos,
   my main curiosity was about the need of the agent for resize.
I did some tests and with both Windows and Linux it appears that the
agent is needed.
At this point I would try looking at the agent logs.
Is your system using Xorg or Wayland ?


I agree with Frediano that (with a recent QXL device) the arbitrary resolution update is done via QXL.
Note that it does not work for all Desktop Environments, and I apparently it doesn't work for AntiX Linux (default DE).
If you can, try to run with GNOME/X11 and see if that works.


> El sáb, 15 oct 2022 a las 9:22, Frediano Ziglio (<freddy77@xxxxxxxxx>) escribió:
>> Il giorno ven 14 ott 2022 alle ore 16:11 Carlos González
>> <piteccelaya@xxxxxxxxx> ha scritto:
>> >
>> > As soon as spice-vdagent package is installed, so is the spice-vdagentd daemon and it also starts running. Yet I always need to manually run spice-vdagent command...
>> >
>> Maybe you would need to logout and login again from the graphic
>> session. Or manually start it, not sure.
>> > How do I specify an output directory for the agent to file transfer?
>> >
>> See "spice-vdagent --help", specifically -f and -o options.
>> > I don't think it's remote-viewer's fault, because I also tested with a Windows guest. With all SPICE stuff properly installed, everything works out of the box: clipboard, resizing, file transfer from host to guest. With "properly installed" I mean: installed SPICE drivers manually from virtio-win ISO by loading them since the Windows installation beforehand, then once booted into Windows downloaded the vdagent ZIP from spice-space website and manually installed the service according to instructions.
>> >
>> I'll check, maybe is not handled by driver but agent
>> > As additional detail, in QEMU I use the option "-display spice-app", which automatically starts remote-viewer; though curiously it doesn't seem to create a virt-viewer directory inside ~/.config unlike when running remote-viewer manually...
>> >
>> > Thanks again.
>> >
>> > El vie, 14 oct 2022 a las 12:41, Frediano Ziglio (<freddy77@xxxxxxxxx>) escribió:
>> >>
>> >> Il giorno gio 13 ott 2022 alle ore 16:58 Carlos González
>> >> <piteccelaya@xxxxxxxxx> ha scritto:
>> >> >
>> >> > Hello.
>> >> >
>> >> > I'm trying a virtual machine with a live CD distribution called AntiX Linux, which is directly based on Debian.
>> >> >
>> >> > I'm using direct QEMU commands.
>> >> > In the VM configuration I have this for SPICE configuration:
>> >> > "-vga qxl -device virtio-serial-pci -spice unix=on,addr=path/to/vm_spice.socket,disable-ticketing=on -chardev spicevmc,id=spicechannel0,name=vdagent -device virtserialport,chardev=spicechannel0,name=com.redhat.spice.0 \"
>> >> > Then I boot the live ISO, double check that QXL driver is installed -which normally always is-, and install spice-vdagent package (version 20 here). I'm using remote-viewer (virt-viewer) to visualize the VM.
>> >> >
>> >> > Up to this point, clipboard sharing with host still doesn't work, and trying to drag a file from host to guest results in an error "The agent is not connected".
>> >> >
>> >>
>> >> This error is normal if the agent is stopped.
>> >>
>> >> > So I manually run "spice-vdagent" command, and clipboard sharing now works, but trying to drag file from host to guest gives "File transfer is disabled". Also, automatic resolution change with window resizing doesn't work either.
>> >> >
>> >>
>> >> The fact that in this way the clipboard is running indicates that the
>> >> agent is now working. You need to specify an output directory to the
>> >> agent in order to get file transfer working.
>> >> About the resolution change that's weird, I think that feature on
>> >> Linux does not even require the agent running. Is it possible that the
>> >> client (remove-viewer) is not set up to send resize to the guest
>> >> automatically, there are some options on the menu.
>> >>
>> >> > Certainly, this live distro doesn't come with any spice-related packages installed by default, except for the QXL package.
>> >> >
>> >> > Am I missing something here? Could someone help please?
>> >> > Thanks beforehand.
>> >>
>> >> Frediano

[Index of Archives]     [Linux Virtualization]     [Linux Virtualization]     [Linux ARM Kernel]     [Linux ARM]     [Linux Omap]     [Fedora ARM]     [IETF Annouce]     [Security]     [Bugtraq]     [Linux OMAP]     [Linux MIPS]     [ECOS]     [Asterisk Internet PBX]     [Linux API]     [Monitors]