> > This fixes make distcheck > --- > This applies on top of the make check-valgrind patch I sent earlier, I can > rebase on top of git master if needed > > Christophe > > server/tests/Makefile.am | 7 ++++++- > 1 file changed, 6 insertions(+), 1 deletion(-) > > diff --git a/server/tests/Makefile.am b/server/tests/Makefile.am > index 86977ab..8237138 100644 > --- a/server/tests/Makefile.am > +++ b/server/tests/Makefile.am > @@ -2,7 +2,12 @@ NULL = > > @VALGRIND_CHECK_RULES@ > VALGRIND_SUPPRESSIONS_FILES = $(top_srcdir)/server/tests/valgrind/glib.supp > -EXTRA_DIST = $(VALGRIND_SUPPRESSIONS_FILES) > +EXTRA_DIST = \ > + $(VALGRIND_SUPPRESSIONS_FILES) \ > + pki/ca-cert.pem \ > + pki/server-cert.pem \ > + pki/server-key.pem \ > + $(NULL) Very OT consideration. This alignment at the end is really hard to maintain and there are different styles and alignment in a single file. Sometimes you need to add a long line and you need to reindent all macro. Also you can't easily move lines as you have also to reindent and tools (like diff) require additional parameter to ignore this. Why not something like EXTRA_DIST = \ $(VALGRIND_SUPPRESSIONS_FILES) \ pki/ca-cert.pem \ pki/server-cert.pem \ pki/server-key.pem \ $(NULL) I don't think is less readable. Frediano _______________________________________________ Spice-devel mailing list Spice-devel@xxxxxxxxxxxxxxxxxxxxx https://lists.freedesktop.org/mailman/listinfo/spice-devel