Re: [PATCH] fixup! Improve encapsulation of DisplayChannel

[Date Prev][Date Next][Thread Prev][Thread Next][Date Index][Thread Index]

 



On Fri, 2016-09-16 at 13:26 +0100, Frediano Ziglio wrote:
> Style fix
> 
> Signed-off-by: Frediano Ziglio <fziglio@xxxxxxxxxx>
Acked-by: Pavel Grunt <pgrunt@xxxxxxxxxx>
> ---
>  server/display-channel.c | 4 ++--
>  server/display-channel.h | 3 +--
>  2 files changed, 3 insertions(+), 4 deletions(-)
> 
> diff --git a/server/display-channel.c b/server/display-channel.c
> index 56bb029..4e643dd 100644
> --- a/server/display-channel.c
> +++ b/server/display-channel.c
> @@ -204,8 +204,8 @@ void
> display_channel_surface_unref(DisplayChannel *display, uint32_t
> surface_id)
>  }
>  
>  /* TODO: perhaps rename to "ready" or "realized" ? */
> -bool display_channel_surface_has_canvas(DisplayChannel *display,
> -                                        uint32_t surface_id)
> +gboolean display_channel_surface_has_canvas(DisplayChannel
> *display,
> +                                            uint32_t surface_id)
>  {
>      return display->surfaces[surface_id].context.canvas != NULL;
>  }
> diff --git a/server/display-channel.h b/server/display-channel.h
> index 022cd93..ba62950 100644
> --- a/server/display-channel.h
> +++ b/server/display-channel.h
> @@ -265,8 +265,6 @@
> void                       display_channel_compress_stats_print     
>  (const Disp
>  void                       display_channel_compress_stats_reset    
>   (DisplayChannel *display);
>  void                       display_channel_surface_unref           
>   (DisplayChannel *display,
>                                                                     
>    uint32_t surface_id);
> -bool                       display_channel_surface_has_canvas      
>   (DisplayChannel *display,
> -                                                                   
>    uint32_t surface_id);
>  void                       display_channel_current_flush           
>   (DisplayChannel *display,
>                                                                     
>    int surface_id);
>  int                        display_channel_wait_for_migrate_data   
>   (DisplayChannel *display);
> @@ -295,6 +293,7 @@ void
> display_channel_update_monitors_config(DisplayChannel *display,
> QXLMonitors
>  void set_monitors_config_to_primary(DisplayChannel *display);
>  
>  gboolean display_channel_validate_surface(DisplayChannel *display,
> uint32_t surface_id);
> +gboolean display_channel_surface_has_canvas(DisplayChannel
> *display, uint32_t surface_id);
>  void display_channel_reset_image_cache(DisplayChannel *self);
>  
>  static inline int is_equal_path(SpicePath *path1, SpicePath *path2)
> 
_______________________________________________
Spice-devel mailing list
Spice-devel@xxxxxxxxxxxxxxxxxxxxx
https://lists.freedesktop.org/mailman/listinfo/spice-devel




[Index of Archives]     [Linux ARM Kernel]     [Linux ARM]     [Linux Omap]     [Fedora ARM]     [IETF Annouce]     [Security]     [Bugtraq]     [Linux]     [Linux OMAP]     [Linux MIPS]     [ECOS]     [Asterisk Internet PBX]     [Linux API]     [Monitors]