Here's an updated version of the series Frediano posted yesterday, but includes some introductory commits that rename some types for improved consistency within the codebase. Christophe Fergeau (10): char-device: Avoid use-after-free char-device: Make SpiceCharDeviceState a GObject spicevmc: Introduce RedCharDeviceSpiceVmc GObject spicevmc: Move SpiceVmcState::pipe_item to RedCharDeviceSpiceVmc smartcard: Turn SmartcardState into a GObject reds: Make VDIPortState private to reds.c reds: Prepare to make VDIPortState a GObject reds: Make VDIPortState a GObject reds: Remove spice_char_device_state_create() Move SpiceCharDeviceCallbacks into RedCharDeviceClass Jonathon Jongsma (5): Rename SpiceCharDeviceMsgToClient to RedCharDeviceMsgToClient Rename SpiceCharDeviceWriteBuffer to RedCharDeviceWriteBuffer Rename SpiceCharDeviceState to RedCharDevice Rename SpiceCharDeviceClientState to RedCharDeviceClient Rename RedCharDevice functions server/char-device.c | 792 +++++++++++++++++++++++++++++--------------------- server/char-device.h | 223 +++++++------- server/reds-private.h | 56 +--- server/reds.c | 693 +++++++++++++++++++++++++------------------ server/reds.h | 3 +- server/smartcard.c | 178 +++++++----- server/smartcard.h | 32 +- server/spicevmc.c | 178 ++++++++---- 8 files changed, 1253 insertions(+), 902 deletions(-) -- 2.4.3 _______________________________________________ Spice-devel mailing list Spice-devel@xxxxxxxxxxxxxxxxxxxxx https://lists.freedesktop.org/mailman/listinfo/spice-devel