[PATCH spice v2 0/4] Rewrite image compress

[Date Prev][Date Next][Thread Prev][Thread Next][Date Index][Thread Index]

 



Hi,

the intention of the series is to make the image compression code more readable
and also to do some clean up. There were two places where an algorithm for choosing
the compression type was implemented - in dcc.c and dcc-send.c. In order to avoid
the duplication, dcc_compress_image() is slightly modified and reused.
The last patch of the series tries to refactor the compression code
to make more clear when each of the compression methods should be used.

Thanks,

Pavel Grunt (4):
  dcc_compress_image: Handle NULL drawable
  dcc-send: Use dcc_compress_image to compress image
  dcc: make dcc_compress_image_*() private
  dcc: Rewrite dcc_image_compress

 server/dcc-send.c |  44 +-----------
 server/dcc.c      | 210 +++++++++++++++++++++++++++---------------------------
 server/dcc.h      |  15 ----
 3 files changed, 109 insertions(+), 160 deletions(-)

-- 
2.5.0

_______________________________________________
Spice-devel mailing list
Spice-devel@xxxxxxxxxxxxxxxxxxxxx
http://lists.freedesktop.org/mailman/listinfo/spice-devel




[Index of Archives]     [Linux ARM Kernel]     [Linux ARM]     [Linux Omap]     [Fedora ARM]     [IETF Annouce]     [Security]     [Bugtraq]     [Linux]     [Linux OMAP]     [Linux MIPS]     [ECOS]     [Asterisk Internet PBX]     [Linux API]     [Monitors]