> > From: Yonit Halperin <yhalperi@xxxxxxxxxx> > > (1) merge 'force' and 'wait_for_outgoing_item' to one parameter. > 'wait_for_outgoing_item' is a derivative of 'force'. > (2) move the call to red_wait_outgoing_item to > red_clear_surface_drawables_from_pipe Surely the original patch must had been bigger then this. Now is just an argument name rename. The rename actually is making the argument name coherent between declaration and definition. I would go for a comment like red_worker: make dcc_clear_surface_drawables_from_pipe declaration consistent with definition (also the name was changed) Frediano > --- > server/dcc.h | 3 ++- > 1 file changed, 2 insertions(+), 1 deletion(-) > > diff --git a/server/dcc.h b/server/dcc.h > index 14981ca..7b8a3b8 100644 > --- a/server/dcc.h > +++ b/server/dcc.h > @@ -204,7 +204,8 @@ void dcc_release_item > (DisplayCha > void dcc_send_item > (DisplayChannelClient *dcc, > PipeItem > *item); > int dcc_clear_surface_drawables_from_pipe > (DisplayChannelClient *dcc, > - int > surface_id, int force); > + int > surface_id, > + int > wait_if_used); > int dcc_drawable_is_in_pipe > (DisplayChannelClient *dcc, > Drawable > *drawable); > _______________________________________________ Spice-devel mailing list Spice-devel@xxxxxxxxxxxxxxxxxxxxx http://lists.freedesktop.org/mailman/listinfo/spice-devel