On Thu, 2015-09-24 at 11:47 -0500, Jonathon Jongsma wrote: > ACK series, thanks! Pushed, thanks Pavel > > On Thu, 2015-09-24 at 18:33 +0200, Pavel Grunt wrote: > > Hi all, > > I noticed that we have a lot of not properly documented symbols in spice- > > gtk. > > My intention was to improve this area before the spice-gtk release. So I am > > sending patches. They are mostly about adding missing descriptions of > > parameters, > > fields and symbols. I also added a new section - Version Information. > > > > Thanks > > > > v2 add addresses Jonathon's comments: > > - new PATCH 2/9 - channel-main: Rename parameter to match docs > > - fixes more typos > > > > Pavel Grunt (9): > > channel-record: Use correct nick name for property > > channel-main: Rename parameter to match docs > > docs: Update for missing symbols > > docs: Add Version Information section > > docs: Move SPICE_TYPE_USB_DEVICE to standard subsection > > docs: Add missing parameter/field descriptions > > docs: Description should be above 'Return' > > docs: Add missing symbol description strings > > docs: Fix typos > > > > doc/reference/spice-gtk-docs.xml | 1 + > > doc/reference/spice-gtk-sections.txt | 24 ++++++++++++---- > > src/channel-display.c | 6 ++-- > > src/channel-inputs.c | 20 +++++++------- > > src/channel-inputs.h | 8 ++++++ > > src/channel-main.c | 36 +++++++++++++----------- > > src/channel-playback.c | 7 +++++ > > src/channel-port.c | 4 +-- > > src/channel-record.c | 6 ++-- > > src/smartcard-manager.c | 3 +- > > src/smartcard-manager.h | 21 ++++++++++++++ > > src/spice-channel.c | 28 +++++++++---------- > > src/spice-channel.h | 14 ++++++++++ > > src/spice-client.c | 7 +++++ > > src/spice-client.h | 5 ++++ > > src/spice-grabsequence.c | 12 ++++++-- > > src/spice-grabsequence.h | 5 ++++ > > src/spice-gtk-session.c | 4 +-- > > src/spice-gtk-session.h | 11 ++++++++ > > src/spice-option.c | 2 ++ > > src/spice-session.c | 16 +++++++---- > > src/spice-session.h | 13 +++++++++ > > src/spice-uri.h | 12 ++++++++ > > src/spice-util.c | 2 ++ > > src/spice-version.h.in | 2 ++ > > src/spice-widget.c | 18 ++++++++---- > > src/spice-widget.h | 21 ++++++++++++++ > > src/usb-device-manager.c | 53 +++++++++++++++++++++++++++++-- > > ----- > > src/usb-device-manager.h | 8 +++++- > > src/usb-device-widget.c | 2 ++ > > src/usb-device-widget.h | 1 + > > 31 files changed, 290 insertions(+), 82 deletions(-) > > > > _______________________________________________ Spice-devel mailing list Spice-devel@xxxxxxxxxxxxxxxxxxxxx http://lists.freedesktop.org/mailman/listinfo/spice-devel