On 07/06/2012 12:46 AM, Marc-André Lureau wrote:
On Thu, Jul 5, 2012 at 11:26 PM, Marc-André Lureau
<marcandre.lureau@xxxxxxxxx> wrote:
On Thu, Jul 5, 2012 at 10:43 PM, Uri Lublin<uril@xxxxxxxxxx> wrote:
+ gboolean filter_ok = FALSE;
Actually, I think "auto_ok" was a more readable name here, since it
affects only the "auto" code path.
--
Marc-André Lureau
+ if (can_redirect&& filter_ok) {
spice_usb_device_manager_connect_device_async(self,
- (SpiceUsbDevice *)device, NULL,
+ device, NULL,
spice_usb_device_manager_auto_connect_cb,
- libusb_ref_device(device));
+ g_object_ref(device));
+ }
Is the g_object_ref() is a left over from a previous version ?
Yes, fixed now.
Thanks,
Uri.
_______________________________________________
Spice-devel mailing list
Spice-devel@xxxxxxxxxxxxxxxxxxxxx
http://lists.freedesktop.org/mailman/listinfo/spice-devel