According to Section 6.2.14 from ACPI spec 6.3 [1], the setting of proximity domain is optional, as below: This optional object is used to describe proximity domain associations within a machine. _PXM evaluates to an integer that identifies a device as belonging to a Proximity Domain defined in the System Resource Affinity Table (SRAT). This patch checks node id with the below case before returning node_to_cpumask_map[node]: 1. if node_id >= nr_node_ids, return cpu_none_mask 2. if node_id < 0, return cpu_online_mask 3. if node_to_cpumask_map[node_id] is NULL, return cpu_online_mask [1] https://uefi.org/sites/default/files/resources/ACPI_6_3_final_Jan30.pdf Signed-off-by: Yunsheng Lin <linyunsheng@xxxxxxxxxx> --- note node_to_cpumask_map[node] is already a pointer, so the cpumask_clear should be called with node_to_cpumask_map[node] instead of &node_to_cpumask_map[node]? And cpumask_of_node() function need to be inlined when defined in a header file? If the above are problems, maybe another patch to fix or clean it up. --- arch/alpha/include/asm/topology.h | 7 +++++-- 1 file changed, 5 insertions(+), 2 deletions(-) diff --git a/arch/alpha/include/asm/topology.h b/arch/alpha/include/asm/topology.h index 5a77a40..9e0b1cd1 100644 --- a/arch/alpha/include/asm/topology.h +++ b/arch/alpha/include/asm/topology.h @@ -30,8 +30,11 @@ static const struct cpumask *cpumask_of_node(int node) { int cpu; - if (node == NUMA_NO_NODE) - return cpu_all_mask; + if (node >= nr_node_ids) + return cpu_none_mask; + + if (node < 0 || !node_to_cpumask_map[node]) + return cpu_online_mask; cpumask_clear(&node_to_cpumask_map[node]); -- 2.8.1