On Wed, Sep 25, 2024 at 8:48 PM Thiébaud Weksteen <tweek@xxxxxxxxxx> wrote: > On Thu, Sep 26, 2024 at 6:11 AM Paul Moore <paul@xxxxxxxxxxxxxx> wrote: > > > > Streamline the code in selinux_nlmsg_lookup() to improve the code flow, > > readability, and remove the unnecessary local variables. > > > > Signed-off-by: Paul Moore <paul@xxxxxxxxxxxxxx> > > --- > > security/selinux/nlmsgtab.c | 90 ++++++++++++++++--------------------- > > 1 file changed, 39 insertions(+), 51 deletions(-) > > > > diff --git a/security/selinux/nlmsgtab.c b/security/selinux/nlmsgtab.c ... > > - /* No messaging from userspace, or class unknown/unhandled */ > > - default: > > - err = -ENOENT; > > + case SECCLASS_NETLINK_AUDIT_SOCKET: > > + if (selinux_policycap_netlink_xperm()) { > > + *perm = NETLINK_XFRM_SOCKET__NLMSG; > > Should it be NETLINK_AUDIT_SOCKET__NLMSG here? Yes it should, thanks! -- paul-moore.com